escaping ampersand in xsl

VERIFIED DUPLICATE of bug 98168

Status

()

VERIFIED DUPLICATE of bug 98168
14 years ago
14 years ago

People

(Reporter: cbandy, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10

Ampersand (& amp; or & #38;) are not properly parsed/escaped inside the xsl:text
tag when disable-output-escaping="yes".

Reproducible: Always
Steps to Reproduce:
1. Create an XML stylesheet to output html
2. Place an (& amp;) inside an xsl:text with disable-output-escaping="yes"

Actual Results:  
Text is interpreted the same with output-escaping disabled as with it enabled.

Expected Results:  
With output-escaping disabled the ampersand should be treated as HTML source,
not text.

Reproducible on Linux:
Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040926 Firefox/0.10
(Reporter)

Updated

14 years ago
OS: Windows 2000 → All

*** This bug has been marked as a duplicate of 98168 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

14 years ago
Reading bug 98168 provided enough information to resolve this issue.

Displaying HTML special chars (like ampersand, infinity, etc.) should be done
with numeric codes instead of the "friendly" code.

To properly output the infinity symbol in my XSL I used ∞ instead of ∞
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.