Closed Bug 262532 Opened 18 years ago Closed 18 years ago

entering a URL with no colon (http//) always loads www.microsoft.com

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 231720

People

(Reporter: rellis.ece02, Assigned: bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10

Type a URL for any site (valid or not) in the Location bar but omit the colon,
as in http//www.xyz.com instead of http://www.xyz.com.  Firefox will
inexplicably load Microsoft's homepage!  The Location bar still shows the
incorrect URL.

Reproducible: Always
Steps to Reproduce:
1.  Type http//www.mozilla.org (notice no ":") in Location bar
2.  Hit enter


Actual Results:  
Microsoft's homepage loads

Expected Results:  
Error message, auto-correct to include a colon in the URL, anything other than
loading www.microsoft.com!


I stumbled across this in a dicussion thread: 
http://www.rage3d.com/board/showthread.php?s=59e78998ba990e0ae15df1e1b96de9f5&t=33773760&page=2&pp=30

*** This bug has been marked as a duplicate of 231720 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.