Closed Bug 262574 Opened 17 years ago Closed 16 years ago

Print Preview in a new window or tab, not in the main browser window

Categories

(Firefox :: General, enhancement)

x86
Windows XP
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 133787

People

(Reporter: g.teunis, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041001 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041001 Firefox/0.10

Print preview isn't opened in a new window anymore but uses the browser window
itself.

Reproducible: Always
Steps to Reproduce:
1. Open an page
2. Use File -> Print Preview

Actual Results:  
The current browser window is reused for displaying the print preview

Expected Results:  
A new window besides the browser window with print preview.
It's no different from other main browsers like IE or Opera.
(In reply to comment #1)
> It's no different from other main browsers like IE or Opera.

Internet Explorer opens a new print preview window besides the browser window,
overlapping the browser window.
I think this is a low priority bug or even en WONTFIX.
In my opinion a new print preview window besides the browser window will enable
users to still use (other) tabs on the browser window while using the print
preview window.
Hey folks,

is there a way to put this one on a higher priority list ;)

I find it really annoying that the print preview opens a new window. I am a
developer and sometimes want to check print layout versus screen side by side.
And opening an extra window with the same URL seems not to be a good option ...

Also, peter, I don't know how you could so easily say "all others do so" while
1st this is not true and 2nd thinking about that it might be useful to _some_ to
have it in an extra window ...

<offtopic>
Greetings to all devs by the way and thanks for the great job on FF and such ;)
</offtopic>
It makes more sense for it to open in a new window - what's the point of tabbed
browsing if you have to stop using all the other tabs in order the preview one?
(In reply to comment #5)
> It makes more sense for it to open in a new window - what's the point of tabbed
> browsing if you have to stop using all the other tabs in order the preview one?

If you're getting ready to print something and previewing it, then immediately
after print preview it seems the only next logical thing to do is print, in
which case you're right back to your tabs.  I don't see this as a high priority,
perhaps at some point an option "open print-preview in new window" under
tools-options would be nice but not a high priority.
I would prefer a new TAB for preview (as an option at least)
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This isn't fixed yet.
When print preview is enabled the rest of the tabs in the browser aren't useable.

Opera opens the print preview _in_ the corresponding tab (other tabs still usable).
Internet explorer opens new preview window on top of the browser window (exactly
on top, you will have to drag it to see the real browser window).
Firefox currently reuses the complete window, disabeling all usage of further tabs.
this is an enhancement, not a bug
Severity: normal → enhancement
This looks like a legitimate request to me - I'm not sure of the compontent
(prefs?) so I'll leave in general.  As it's an RFE, I've altered the summary
accordingly.  I'm also going to confirm the bug.

BTW, bug 177491 is in a sense related.  That is about the fact that opening a
link from an external app while in print preview really screws things up.  I
guess with a new window for print preview, this type of problem would be avoided.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Print Preview should open in a new window, not reusing the browser window → Print Preview in a new window or tab, not in the main browser window

*** This bug has been marked as a duplicate of 133787 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Damn.  Didn't think to search for "separate"!
You need to log in before you can comment on or make changes to this bug.