Reload fails to reflect changes in Selected attribute in select/option Form inputs

VERIFIED DUPLICATE of bug 46845

Status

()

Firefox
General
--
minor
VERIFIED DUPLICATE of bug 46845
13 years ago
13 years ago

People

(Reporter: Paul Whittney, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10

Using the http://www.w3.org/MarkUp/Test/HTML401/current/tests/sec17_6_1-BF-01.html 
as an example (sorry, can't really think of a way to show it due to a backend
database being used). First load of the page has the "cashews" corrected
selected due to the OPTION SELECTED in the HTML source. If you change that entry
to any other possible option, and hit the reload toolbar button or via the right
mouse click this frame -> reload this frame entry, but the user option failed to
revert to the SELECTED option. However, a SHIFT-Reload of the page causes the
correct changes to occur.

Maybe this is for user entries, and the caching of those changes, and if thats
the case, sorry for bothering you with this false bug.

The only reason I see this issue as a bug, is due to the fact that if the OPTION
SELECTED line is generated as a dynamically generated page with a database
providing the OPTION lines, and therefore at time=t the first option is selecte,
(correctly). At time=t+30sec the database receives an update from a non-browser
source. At time=t+60sec the firefox browser reloads the page, and the page
source clearly shows that the OPTION SELECTED line has correct moved to match
the data optained from the database, however, the browser shows the last entry
until a SHIFT-Reload occurs. Moving off the page and returning (via html links
on the page) results in the correct behaviour.

Reproducible: Always
Steps to Reproduce:
1. load page with a SELECT section in a form tied to a backend database
utilizing OPTION and OPTION SELECTED statements.
2. Use the database (via the mysql command line for example) to alter which
option should be selected via an update statement.
3. Reload the page using the toolbar reload button

Actual Results:  
The option will remain the same, even though a page source shows that the
selected value is on a different option (showing that firefox went out and
queried the actual page)

Expected Results:  
The new option should be selected in the combo box to match what the source code
has.

Tried pragma no-cache in case the data is in the browsers no cache, but the page
source contains the correct data, but the browser is showing the previos value.

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.