Home and End keys do not function properly

VERIFIED WORKSFORME

Status

()

Toolkit
View Source
VERIFIED WORKSFORME
14 years ago
10 years ago

People

(Reporter: Dean Tessman, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

1.7 Branch
x86
Windows 2000
Points:
---
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Now that there's a cursor in View Source, Home and End should take me to the
start or end of the current line, respectively.  Currently they take me to the
start or end of the document.
(Reporter)

Updated

14 years ago
Flags: blocking-aviary1.0?

Comment 1

14 years ago
I don't think we'd block the 1.0 release on a view source keyboard issue. feel
free to request approval if a reviewed patch materializes.
Flags: blocking-aviary1.0? → blocking-aviary1.0-

Comment 2

14 years ago
Mozilla Help, Keyboard Shortcuts, says:
"Homekey" = "Go to Top of Page"

This shortcut does not appear to work. 
Pressing "Home" does nothing.

Comment 3

14 years ago
theoglobal@yahoo.com: please be nice and indicate what browser you're using
(complete useragent), also if you're using a usb keyboard or a laptop keyboard
it might be a good idea to indicate the make and model.

Comment 4

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041103
Firefox/1.0RC2
Home and End works as help says
And since there is no cursor, this is ok for me
(Reporter)

Comment 5

14 years ago
(In reply to comment #4)
> And since there is no cursor, this is ok for me

You're right.  The cursor only appears after successfully searching for text. 
Then the arrows move the cursor, whereas before searching they scrolled the page.

Comment 6

14 years ago
Also CntlCmd+Home does not take browser to 'Top of Page'

    I searched the HelpGuide and it does not show the keyboard shortcut
CntlCmd+Home as being assigned to anything. To be consistent with other
Microsoft Office and IE functions, it would seem logical to also assign this key
sequence to the appropriate action in FireFox.

CntlCmd+End does however work correctly and goes to 'Bottom of Page'

-John

Comment 7

14 years ago
Two issues:

1) According to Help pages, HOME key is supposed to display the Top of page, End
key to display the bottom of page.  This is inconsistent with Windows convention
where Home key moves the cursor to the beginning of line, End key to the end of
line.  Ctrl-Home is supposed to display the top of the page, Ctrl-End to the
bottom of the page.

2) With Windows XP SP1, Home key does not work like it is described in Help
pages.  It does not always display the top of the page. e.g. Try this page with
the Home and End keys: http://www.mozilla.org/wishlist-faq.html  You'll notice
that the cursor is stuck at the bottom of the page.

Comment 8

13 years ago
This behavior is inconsistent when holding Shift to select text; the Shift+Home
and Shift+End keys extend the selection to the start, resp. end of the line,
while Shift+PageUp and Shift+PageDown are ignored.

Comment 9

13 years ago
Home and End keys do function properly. It's just that the focus is set outside
the content area when View Source is displayed. Anybody objects morphing this
bug into "give the content area focus on View Source load"?

Comment 10

13 years ago
Just tested this on branch, and it indeed was a problem in 1.0.
This is fixed on trunk though, marking WFM.

The bug mentioned in comment 9 is separate.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050325
Firefox/1.0+
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 11

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050325
Firefox/1.0+

I verify WFM on latest-trunk.
Status: RESOLVED → VERIFIED

Comment 12

13 years ago
Just a note, you have to actually click the content area first and make the
caret visible before hitting home or end in order for this to work.

Comment 13

13 years ago
*** Bug 303894 has been marked as a duplicate of this bug. ***
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.