Allow filters to do automatic housekeeping of mail folders. (Filters based on age should run automatically.)

RESOLVED DUPLICATE of bug 59365

Status

MailNews Core
Filters
--
enhancement
RESOLVED DUPLICATE of bug 59365
14 years ago
10 years ago

People

(Reporter: John David Galt, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

1.7 Branch
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Win98; rv:1.7.3) Gecko/20040913 Firefox/0.10

I would like to be able to set filters to be automatically applied to specific
mail folders (including those under Local Mail) each time Thunderbird starts up,
so that (for example) I can have a "Current Headlines" folder automatically
purge all messages over 90 days old which I have not set to high priority --
thus avoiding the need for ongoing manual housekeeping.

Reproducible: Always
Steps to Reproduce:
N/A

Comment 1

14 years ago
The UI is there: create a filter using the "Age in days" property.  The problem
is that filters are only run when the message first enters the folder, so
filters using the "Age in days" property don't work.

Filters with the "Age in days" property should run automatically when the
message's age increases beyond the threshold, or automatically on all messages
after checking for mail, or something.
Assignee: mscott → sspitzer
Status: UNCONFIRMED → NEW
Component: General → Filters
Ever confirmed: true
Product: Thunderbird → MailNews
Summary: Allow filters to do automatic housekeeping of mail folders. → Allow filters to do automatic housekeeping of mail folders. (Filters based on age should run automatically.)
Version: unspecified → 1.7 Branch
Product: MailNews → Core

Comment 2

13 years ago
This is probably a dup of bug 59365. At least a dependency if not.
Depends on: 59365
(Reporter)

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 59365 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

11 years ago
No longer depends on: 59365
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.