Fatal error [-618]: Couldn't open xpistub library using RedHat 8.0; no problem with SUSE

VERIFIED DUPLICATE of bug 246173

Status

()

Firefox
Installer
--
critical
VERIFIED DUPLICATE of bug 246173
14 years ago
12 years ago

People

(Reporter: Bill, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040913
Build Identifier: firefox-1.0PR-i686-linux-gtk2+xft-installer.tar.gz (downloaded Oct. 2, 2004)

While trying to install Firefox on a Linux RedHat 8.0 operating system, the
following error message surfaced: Fatal error [-618]: Couldn't open xpistub
library.  This occurred while extracting libplc4.so.  This problem did not occur
while installing Firefox on a Linux SUSE 9.1 Professional system.  The same
Linux RedHat 8.0 system easily installed an upgrade of Mozilla 1.7.3 after the
failure to install Firefox.  I have seen similar reports for earlier versions of
Mozilla in which it was suggested to simply move libxpistub.so to another file.
 I tried placing this file in several other places to no avail.  I was puzzled
by the Firefox error message in light of the easy Firefox install on SUSE and
the easy Mozilla upgrade on RedHat.

Reproducible: Always
Steps to Reproduce:
1.Use a RedHat 8.0 operating system
2.Follow the general install instructions for Mozilla
3.Get the fatal error listed above and below.

Actual Results:  
Fatal error [-618]: Couldn't open xpistub library

Expected Results:  
Install Firefox

Following the general install instructions worked for Mozilla 1.7.3 under RedHat
8.0 and worked for Firefox on SUSE 9.1 Professional.  Odd that it would not work
for Firefox on RedHat 8.0.  Need better install documentation for Firefox in any
event.  Hope this helps.

I have listed the bug as "critical" only because it stops one from even getting
started.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 246173 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Updated

12 years ago
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.