Would like pref to display HTML mail in fixed pitch font

RESOLVED DUPLICATE of bug 30896

Status

--
enhancement
RESOLVED DUPLICATE of bug 30896
14 years ago
14 years ago

People

(Reporter: stefan, Assigned: sspitzer)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040910

Our company uses an Exchange mail server, which takes all incoming plaintext
messages and wraps them in HTML. Unfortunately, the result is that Mozilla mail
will no longer display these using the Fixed Width font, but will instead
display them using the default HTML display font. The problem is that many mails
that come in as plain text are plain text for a reason, such as the requirement
that columns line up.

If I change my global Appearance|Fonts preference to use a Fixed Width font for
web pages, then the mail displays fine, but web pages look ugly. I wish there
were a separate preference to specify the font used to display HTML messages.

Reproducible: Always
Steps to Reproduce:
1. Receive an HTML e-mail
2. Look at it
3.

Comment 1

14 years ago
Is this option not sufficient?
  View | Message Body As | Plain Text
The effects of "View as plain" are not quite what he's asking. That'll work
great for the HTML-wrapped plaintext messages, but regular HTML messages won't
contain any rich-text goodies as they would if only the font changed. Some HTML
mails don't display at all.

I personally like View as plain, but it's not the same as this request. Bug
29628 is closer but still not the same. I found references in old bugs to how
this might be nice. Bug 31907 seems to cover it, but it's pretty dead.

*** This bug has been marked as a duplicate of 31907 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 3

14 years ago
That bug itself is only about creating a new pref pane, not about creating new
prefs. New HTML prefs  would be blockers for that bug.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

14 years ago
jglick's UI proposal in bug 30896 would fix this.

Note that, if you use separate instances and profiles for mail and browser, you
can use the generic font prefs, set the "Proportional" font to a fixed font and
enable "always use my fonts".

*** This bug has been marked as a duplicate of 30896 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.