Navigation toolbar does not display properly(black boxes around buttons) when running through Terminal Services with color depth of 256

RESOLVED DUPLICATE of bug 172307

Status

()

Firefox
Menus
RESOLVED DUPLICATE of bug 172307
13 years ago
11 years ago

People

(Reporter: james, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

The navigation toolbar gets black boxes around the buttons when running through
windows 2000 terminal services

Reproducible: Always
Steps to Reproduce:
1.install firefox on windows 2000 terminal server
2.login remotely to server, open firefox
3.

Actual Results:  
navigation buttons don't display properly

Expected Results:  
should have displayed properly

problem also happens when using themes

Comment 1

13 years ago
WFM in a Win 2003 Terminal Service Session.

Comment 2

13 years ago
James: are you still experencing this problem with a nightly build?

Comment 3

13 years ago
Created attachment 166024 [details]
Black boxes in toolbar and around buttons

Similar bug (according to your description) occuring now and then in Windows
98.
Does this look anything like your problem with Terminal Servers?

Comment 4

13 years ago
I see this bug, too, on windows 2000 server.

Additionaly, Firefox is also not using as many colors as it could. Some parts,
like the scrollbar, statusbar, and tabs bar, appear the correct color (light
tan), but the toolbar and menus are grey. See the screenshot for details. In the
Firefox Start page, you can also see lots of dithering going on in the
background and logo.

(Since this bug is not just the menus, it is the entire display, it should go in
a different component. It's probably not in 'firefox' at all.)

Comment 5

13 years ago
Created attachment 170416 [details]
Screenshot showing colors and black boxes

Screenshot showing the dithering and black boxes. Note also that some parts of
the screen are tan while others are grey.

Updated

13 years ago
Summary: Navagation toolbar does not display properly(black boxes around buttons) when running through windows 2000 Terminal Services → Navigation toolbar does not display properly(black boxes around buttons) when running through windows 2000 Terminal Services

Comment 6

13 years ago
I also see this behaviour on w2k 2000 terminal server.
I have also noticed the color of some webpages is not what it should be.

Updated

12 years ago
Assignee: firefox → nobody
QA Contact: bugzilla → menus

Comment 7

12 years ago
Ok - I just experenced this bug.

Firefox 1.5 Win XP - 
My RDC Connection was in 256 colors - When I changed it to true colors - it works.
Summary: Navigation toolbar does not display properly(black boxes around buttons) when running through windows 2000 Terminal Services → Navigation toolbar does not display properly(black boxes around buttons) when running through Terminal Services with color depth of 256

Comment 8

12 years ago
dupe of bug 172307 ?

Comment 9

11 years ago

*** This bug has been marked as a duplicate of 172307 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.