Closed Bug 26314 Opened 21 years ago Closed 21 years ago

arrow keys "->" and "<-" do not work in viewer

Categories

(Core :: DOM: Editor, defect, P3)

defect

Tracking

()

VERIFIED DUPLICATE of bug 24645

People

(Reporter: yixiong.zou, Assigned: Brade)

Details

Attachments

(1 file)

arrow keys "->" and "<-" don't work in viewer any more because currently these 
are taken care of by XUL.
since viewer does not have XUL. These operation should be done by editor. 
Component: Viewer App → Editor
I am sending a patch. Apparently this fixes the problem. Could anyone check 
this in?
Handing to beth for triage.
Assignee: rickg → beppe
assigning to buster -- Steve, what do you think?
Assignee: beppe → buster
The patch that I submitted is really a bad solutions though. Cause the rest of 
the keys still won't work, for example, HOME, END, PAGE UP, PAGE DOWN, etc. 

I think it will be sweet if someone can tell me how to hook nsEditorController 
to the nsEditorEventListeners interface. I can try to hook that in. 
mike, kathy, and akkana are working on this problem, not me.  so assigning to 
kathy, cc-ing the others.  in general, the sort of hack proposed here is bad for 
lots of reasons, and is no substitute for proper key bindings.  this patch will 
cause more problems than it will solve.
I believe the plan is to enable key bindings in the absence of XUL.  So this 
problem should go away.
Assignee: buster → brade
No patches.  This is what I'm working on... namely converting the key bindings 
from XUL to XBL.  You'll notice that text fields now work again in viewer.  Next 
I'm converting over the browser and editor key bindings to XBL.  This bug should 
be marked as a dup of my "Convert Ender key bindings to XBL" bug.  Once I do 
that, this bug will be fixed.
Do you have an estimated time frame for the real fix? Thank you.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
as hyatt suggested, I'm marking this as a dup

*** This bug has been marked as a duplicate of 24645 ***
setting milestone, this needs to be verified
Target Milestone: --- → M15
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.