Saved form information can be set into a readonly field and submitted

VERIFIED DUPLICATE of bug 256079

Status

()

VERIFIED DUPLICATE of bug 256079
14 years ago
10 years ago

People

(Reporter: stealthv, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10

On a readonly field, firefox will still show the pop-up with previously entered
data for that field. The user can select from the list and change the content of
the readonly field. This new data will also get submitted with the form.

Reproducible: Always
Steps to Reproduce:
1. The hard part is getting a readonly field to actually have information in the
pop-up. A way to do this would be to start with a field that isn't readonly and
enter some values. Once firefox has a few different values saved make the field
readonly.
2. Double click on the readonly field and the pop-up will appear.
3. Select a value and it will be set in the field.
4. Submit the form.

Actual Results:  
The data in the readonly field was changed.

Expected Results:  
Not changed the readonly field.
This was fixed by bug 256079.

*** This bug has been marked as a duplicate of 256079 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.