if a webpage form selectbox changes while viewing it, refreshing does not update the form

VERIFIED DUPLICATE of bug 46845

Status

()

Toolkit
Form Manager
VERIFIED DUPLICATE of bug 46845
13 years ago
9 years ago

People

(Reporter: Matthew Velie, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

If you look at a webpage with a form and a drop down box and one item in the
html code is selected that is the one that is shown.  If the code of the page is
changed while you are visiting it, a refresh does not show the new and current
selected option, the old one is still selected although the code clearly shows
that another option should be the selected one.  If you hit back and then
forward or somehow navigate off the page then there is no problem, but just a
refresh does not fix the problem.

Reproducible: Always
Steps to Reproduce:
1.View Webpage with form and select box, have one item selected in HTML Code
2.Change which item is selected by moving "selected" to another item, save page.
3.Click the refresh button

Actual Results:  
The old item that was selected is still selected although when viewing the
source you can see that the new one should be selected.

Expected Results:  
New option in the option drop down box should be selected instead of the old one.
use ctrl-F5 to really reload the page

Comment 2

13 years ago
(In reply to comment #1)
> use ctrl-F5 to really reload the page

Indeed. However, I think using the 'reload' button should be equal to using
ctrl-F5 if (one of) these meta-tags have been set:

<meta http-equiv="pragma" content="no-cache">
<meta http-equiv="Cache-control" content="no-cache">

This is not the case now.

The same problem happens with all kinds of form fields: like radio buttons
and checkboxes and other input fields.

What use is it to keep all fields that one filled in as is, if one decides
to reload the page? What other reason could there be to reload a page with
a form, other than to get rid of what one filled in?

Comment 3

13 years ago
> use ctrl-F5 to really reload the page

the described behaviour of the Attribut "selected" in the Tag <select><option>
confuses while developing dynamic FORMS such as with PHP/Perl, and therefore
causes unwanted troubles Code debugging troubles for web developers.

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.