If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[REGRESSION] Can't enter more than 2 addresses

VERIFIED DUPLICATE of bug 26618

Status

MailNews Core
Composition
P1
major
VERIFIED DUPLICATE of bug 26618
18 years ago
9 years ago

People

(Reporter: Richard Zach, Assigned: Chris Waterson)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
On Linux build 2000.02.02.09, message compose address widget doesn't let me
enter more than two addresses.  Happens in both HTML and plain text compose.

To reproduce:
1. New Msg
2. Enter first email address
3. Hit Enter
4. Enter second address
5. Hit Enter

Actual result: nnothing happens
Expected result: third address line added, focus on third address text box

If a third address is added using the address picker, I get the phenomena
described in bug 25103.
Thanks Zach for this very clear and complete bug report.

The problem appends on all platforms.
Status: NEW → ASSIGNED
OS: Linux → All
Hardware: PC → All
Target Milestone: M14
dogfood
Summary: [REGRESSION] Can't enter more than 2 addresses → [REGRESSION][dogfood] Can't enter more than 2 addresses

Comment 3

18 years ago
Moving [Dogfood] in Summary to "dogfood" in keyword
Keywords: dogfood
Summary: [REGRESSION][dogfood] Can't enter more than 2 addresses → [REGRESSION] Can't enter more than 2 addresses
The problem is apparently due to a Waterson's checking.

Waterson ask me to set the onkeyup attribute after the new node is inserted in 
the tree. I did that but it didn't fix the problem. However, if I wait for a 
reflow after the new node is inserted to set again the onkeyup attribute, then 
it works again. But it's a hack, not a fix!

Reassign to waterson
Assignee: ducarroz → waterson
Status: ASSIGNED → NEW

Comment 5

18 years ago
Putting on PDT+ radar.
Whiteboard: [PDT+]
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Priority: P3 → P1
(Assignee)

Comment 6

18 years ago
Created attachment 4917 [details] [diff] [review]
fix, part 1
(Assignee)

Comment 7

18 years ago
Jean-Francois, see patch. Explicitly sets the event handler on the input field. 
Yeah, this sucks: I wish that cloneNode() would do it, because it would get rid 
of the whole "copy node and it's kids" routine. So, this is part one of the 
fix.

Now, after hitting enter a second time, I crash in the tree widget code trying 
to initialize a titledbutton. Looking for that now...
*** Bug 26577 has been marked as a duplicate of this bug. ***

Updated

18 years ago
QA Contact: lchiang → laurel

Updated

18 years ago
Blocks: 16924

Comment 9

18 years ago
Added info, mac only: 
On mac if I try to add 3 or more addressees through use of the address picker,
mozilla freezes.  (other mac freeze kinda related, see bug #26618)
(Assignee)

Comment 10

18 years ago
Ok, it turns out that the crash I was seeing was due to cruft in my tree from a 
panicky backout a couple of days ago. I've since removed it, and this fix is 
rocking so hard.
(Assignee)

Comment 11

18 years ago
fix checked in, r=mscott
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

18 years ago
Still broken on Linux build 2000.02.06.09.  Now, after you hit enter on the
second email address, Mozilla becomes unresponsive.  
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 13

18 years ago
This WORKSFORME. Let's see what QA says when the builds come out Monday.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
I just added a patch in my JS to reset all the "on..." attributes of the new 
added node after the first reflow. Therefore Message Compose should not be 
affected by this problem anymore

Comment 15

18 years ago
Reopening...

Using 2000-02-09-08m14 commercial build on linux rh6.0 -- freezes on trying to
get to 3rd addressee line

Using 2000-02-09-08m14 commercial build on mac OS 9.0 -- freezes on 3rd address
line

Using 2000-02-09-08m14 commercial build on NT 4.0 -- OK.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 16

18 years ago
This is a dup of my bug.


*** This bug has been marked as a duplicate of 26618 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 17

18 years ago
Ok, marking verified as duplicate.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.