Closed Bug 263576 Opened 18 years ago Closed 18 years ago

Chinese character cann't be display correct when useing apache'mod mod_auth_ldap

Categories

(Core :: Networking, defect)

All
Linux
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 41489

People

(Reporter: pywy, Assigned: darin.moz)

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: 

when I useing apache'mod mod_auth_ldap and write the "AuthName" in Chinese,the 
mozilla wonn't display the character correct. But IE's well.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Assignee: p_ch → darin
Component: Bookmarks → Networking
QA Contact: seamonkey.bookmarks → benc
mod_auth_ldap?

reporter: can you please give more details on how to reproduce this problem?
I suppose the XXX comment at:
http://lxr.mozilla.org/seamonkey/source/netwerk/protocol/http/src/nsHttpChannel.cpp#2430
might be related.

same as bug 41489?

what exact http header is the server sending?
is that what we are talking about here?  reporter: please clarify.
I use apache2.0 with the module mod_auth_ldap to limit especial directory by 
user's uid and userPasswd.My httpd.conf file is here:
<Directory /home/public_html>
AuthName "Welcome to My home!"
AuthType Basic
AuthLDAPEnabled on
AuthLDAPURL ldap://192.168.20.222/ou=people,dc=ttsoft,dc=com,dc=cn?uid??
(department=ABC)
require valid-user
</Directory>
The operation "AuthName" will display on pop-up windows,when user are 
visiting "/home/public_html" from the web.
My question is, If I change the "Welcome to My home!" to non-english word,for 
example a Chinese,the pop-up windows will not display correct.
thank you for the extra info... definitely a duplicate then.

*** This bug has been marked as a duplicate of 41489 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
V/dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.