Menus are not "attached" to the window / window jumps

VERIFIED DUPLICATE of bug 32276

Status

()

defect
P3
minor
VERIFIED DUPLICATE of bug 32276
20 years ago
11 years ago

People

(Reporter: jstultz, Assigned: mikepinkerton)

Tracking

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

20 years ago
Running the nightly build for 2/2/00, I notice that the dropdown menu's are not
attached to the window. If I pull down a menu, enter a submenu, then mouse over
to the window title and drag the window around, the menu drops behind the window
and sticks to the background until I click somewhere. This occurs about half of
the time(might have something to do with entering or not entering a submenu),
with the other half of the time, the menu correctly disappears, but the window
"jumps" somewhere on the screen durring the move.

Expected functionality: Dropdown menu should always disappear when titlebar is
clicked, or menu should remain attached to the window. Window should not jump.
post beta
Status: NEW → ASSIGNED
Target Milestone: M15
moving all defects not directly related to P0 beta2 features off to M18.
Target Milestone: M15 → M18
Depends on: 32276
hey, shrir, is this what you've been seeing? you had mentioned something about
the "tab" highlight erratically disappearing around the menu label (in the
menubar)... related/seperate issue...?

Comment 4

20 years ago
I see the highlighting going off after doing some random browssing. Do not have 
exact steps to recreate that. I ain't sure if that relates to this bug..

Comment 5

20 years ago
Mass moving M18 bugs to M19
Target Milestone: M18 → M19

Comment 6

19 years ago
mass-moving all bugs to m21 that are not dogfood+ or nsbeta2+ or nsbeta2-
Target Milestone: M19 → M21
*spam*: transferring current XP Menu bugs over to jrgm, the new component owner.
feel free to add me to the cc list (unless am the Reporter) of any of these, if
you have any questions/etc.
QA Contact: sairuh → jrgm
i only see this with context menus, and i'm sure it has to do with bug 32276.


*** This bug has been marked as a duplicate of 32276 ***
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE

Comment 9

19 years ago
The bug this has been duped against has been resolved, and I'm no longer
observing the described behavior at all under Linux build 2000110421. Verified dupe.
Status: RESOLVED → VERIFIED

Updated

11 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.