Firefox.exe still open after closing main window(browser) and then download completes

RESOLVED DUPLICATE of bug 239223

Status

()

Toolkit
Downloads API
--
critical
RESOLVED DUPLICATE of bug 239223
13 years ago
9 years ago

People

(Reporter: Bob, Assigned: Blake Ross)

Tracking

1.7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

When you download a file and have the "close download manager when download is
complete" checked, close the main browser window, and let the download finsih. 

When you view your system processes in the task manager (CTRL+ALT+DEL) you will
see that firefox.exe remains open even after the download name is changed from
<name>.<ext>.part to <name>.<ext>.

You have to manually shutdown firefox.exe to relaunch the browser.

Reproducible: Always
Steps to Reproduce:
1. Make sure that both the settings in the Download section's "Download Manager"
are selected
2. Download a file that will take a minute or two to get
3. after a few seconds of downloading, close the main browser window, but leave
the download manager open

Actual Results:  
firefox.exe will remain an open process in Windows XP even after the download is
completed

Expected Results:  
Terminated the firefox.exe process
(Reporter)

Updated

13 years ago
Severity: major → critical
Component: General → Download Manager
Version: unspecified → 1.0 Branch

Comment 1

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041018 Firefox/1.0

This no reproductible for me.

I don't have this problem.

Comment 2

13 years ago
A person that i know has this problem i bleieve so do you have a soulution 
yet??? if not i am going to find one.

Comment 3

13 years ago
WFM - Zip Branch Build.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041030
Firefox/1.0RC2

Comment 4

13 years ago
I have a similar problem with Firefox not truly closing right but it mostly
happens on only one of my computers.  However, it seems fairly random and
doesn't just happen when closing the main window and leaving the download window
open.  

Happens with multiple profiles on 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225
Firefox/1.0.1

and

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20041107 Firefox/1.0

Comment 5

13 years ago
Somehow, this feels like bug 239223.

*** This bug has been marked as a duplicate of 239223 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.