If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Toolbar Buttons on the Help Viewer don't show with okhotska theme.

RESOLVED INVALID

Status

SeaMonkey
Help Viewer
RESOLVED INVALID
13 years ago
2 years ago

People

(Reporter: Tatsuo TANABE, Assigned: Jeff Walden (gone starting June 8))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10

In the Help viewr, there lack some toolbar buttons with using Okhotska theme.

Reproducible: Always
Steps to Reproduce:
1.Install Okhotska theme from http://www.okhotska.net/okhotska/ to Firefox 1.0RC.
2.Select Okhotska to use and then Restert your FF.
3.Open Help Viewer.

Actual Results:  
Some toolbar buttons on Help viewer are missing.

Expected Results:  
Help viewer should shows all tool bar buttons correctly (using with Okhotska
Buttons OR Default Theme Buttons).

This bug is caused by "chrome://help/skin/help.ccs"'s static reference to
"chrome://help/skin/Toolbar.png".
The help.css is  premised on the "chrome://help/skin/Toolbar.png", the Tool Bar
Images of the default Theme.
The example of the code lines that causes this bug are bellow (line 41 to 45 of
help.css);

.toolbarbutton-1 {
	-moz-box-orient: vertical;
	min-width: 0px;
	list-style-image: url("chrome://help/skin/Toolbar.png");
}

help.css shouldn't reference to other component that way, or help.jar should
include all using icons in itself.
(Reporter)

Comment 1

13 years ago
Created attachment 161671 [details]
screenshot

This is the screenshot of the Help viewer using with Okhotska theme.
(Assignee)

Comment 2

13 years ago
When you use a Firefox theme, pretty much everything you see within Firefox
(including within Help) is the way it is (graphics, spacing, fonts, etc.)
because of the theme.  The absence of Help images is completely due to your use
of the theme.  Because Firefox only provides one theme, we only support one
theme (naturally -- why would we support something we didn't directly control?).

Please contact the theme maintainer regarding this bug.  He's the one who can
fix this, not us.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

13 years ago
I'm the Auther of that theme.

I think it is wrong that help.jar using default theme style sheet directly.
If each theme auther must treat to help viewer , as you say, I think that theme
related files in help.jar shuld be placed in classic.jar, not in help.jar itself.

(In reply to comment #3)
> I think it is wrong that help.jar using default theme style sheet directly.
> If each theme auther must treat to help viewer , as you say, I think that
> theme related files in help.jar shuld be placed in classic.jar, not in
> help.jar itself.

This is how extensions to Firefox work, and as Firefox Help is a built-in
extension, this is the way it should be done.  Many other theme authors have
made their themes work with Firefox Help, so I know it's possible.  Try asking
in the Mozillazine Themes forum for help:

http://forums.mozillazine.org/viewforum.php?f=18
(Reporter)

Comment 5

13 years ago
at first, I apologize to you to my false citation of code lines at first comment.

collect citation is berrow;
.browserButton {
  -moz-box-orient: vertical;
  min-width: 0px;
  list-style-image: url("chrome://browser/skin/Toolbar.png");
}
at lines 47 to 51 of help.css.



(In reply to comment #4)

> This is how extensions to Firefox work, and as Firefox Help is a built-in
> extension, this is the way it should be done. 

  I wasn't know help viewer is a built-in extension.
I assumed it as a part of firefox itself.
My misunderstanding makes me to open this bug, so I have no objection to mark
this bug as RESOLVED and INVALID, in this occasion.

> Many other theme authors have
> made their themes work with Firefox Help, so I know it's possible.  Try asking
> in the Mozillazine Themes forum for help:
> 
> http://forums.mozillazine.org/viewforum.php?f=18

 Yes, I know it possible. 
But some elderly themes such as pinball don't support help viewer tool bar icons.
And I think it indicates that root of that problem is Help viewer's using way to
"chrome://browser/skin/Toolbar.png", isn't it?

Well, either way, I move this discussion to other place.

Thank you for your advices.

Updated

13 years ago
Component: Help Viewer → Help Viewer
Product: Firefox → Toolkit
Product: Toolkit → Seamonkey
You need to log in before you can comment on or make changes to this bug.