[PP]Page goes black when color is switched to 8- from 16-bit

VERIFIED DUPLICATE of bug 6061

Status

Core Graveyard
GFX
P3
normal
VERIFIED DUPLICATE of bug 6061
20 years ago
10 years ago

People

(Reporter: cpratt, Assigned: Patrick C. Beard)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
To reproduce this, load a page (I used http://uk.imdb.com) in seamonkey while
your display is set to 16-bit color. When it's finished, switch the color depth
to 8-bit using the control strip (or whatever). The page background goes black
(from white). 24-Jan-99 build.

Comment 1

20 years ago
Setting all current Open/Normal to M4.

Updated

20 years ago
Component: Macintosh FE → Layout
Product: Mozilla → NGLayout

Comment 2

20 years ago
Changed platform to NGLayout to get the right Component selection

Updated

20 years ago
Assignee: sdagley → michaelp

Comment 3

20 years ago
Looks like when switching between absolute and indexed color there's some
confusion over the black and white palette entries (they're typically at opposite
ends of the palette between Mac and Win32 and we're only seeing the problem on
the Mac)

Comment 4

20 years ago
Reassigned to <dcone>.

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 5

20 years ago
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser
(Reporter)

Updated

19 years ago
Summary: Page goes black when color is switch to 8- from 16-bit → Page goes black when color is switched to 8- from 16-bit

Updated

19 years ago
Target Milestone: M4 → M5

Updated

19 years ago
Summary: Page goes black when color is switched to 8- from 16-bit → [PP]Page goes black when color is switched to 8- from 16-bit

Updated

19 years ago
Target Milestone: M5 → M6

Updated

19 years ago
Target Milestone: M6 → M7

Updated

19 years ago
Target Milestone: M7 → M9

Updated

19 years ago
Component: Layout → Compositor

Updated

19 years ago
Target Milestone: M9 → M11

Updated

19 years ago
Target Milestone: M11 → M12

Updated

19 years ago
Assignee: dcone → beard
Status: ASSIGNED → NEW

Comment 6

19 years ago
This needs to have the depthChanged event supported.

Comment 7

19 years ago
Look at the window implementation.. this should delete the offscreen buffer and
create a new buffer and deviceContext at the correct depth.  Then re-layout into
this new buffer.  If you need any help at the graphics level just let me know..
currently to get things working.. that event needs to be supported in the view.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M12 → M13
(Assignee)

Updated

19 years ago
Target Milestone: M13 → M15

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 6061 ***
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 9

19 years ago
Grudging verifying as duplicate of later bug. :)
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.