Closed Bug 263956 Opened 15 years ago Closed 15 years ago

Filepicker dialog opens into new tab (Linux)

Categories

(Firefox :: Tabbed Browser, defect, critical)

1.0 Branch
x86
Linux
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox1.0

People

(Reporter: danm.moz, Assigned: danm.moz)

References

Details

(Keywords: crash, fixed-aviary1.0, regression)

Attachments

(1 file)

Open Edit Menu -> Preferences. Set Force links that open new windows to open in:
a new tab (or into the same tab/window). Using about:config, ensure that the
pref browser.link.open_newwindow.restriction is set to 0 (the default).

1. navigate to http://www.mozilla.org/products/firefox/index.html
2. left click Free Download
3. open/save window pops up, choose Save

that'll bring up chrome://global/content/filepicker.xul in a new tab (or the
current tab, depending on the choice made in the Preferences dialog).

Reported by dirtyepic http://forums.mozillazine.org/viewtopic.php?t=143698
Confirming
Following reporter's steps, I can confirm.

Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.3) Gecko/20041011 Firefox/0.10

This totally breaks (prevents) all downloading. None of the buttons will work,
the download manager can only be closed by closing the tab.

"Ask me where to save every file" must be chosen as well, in addition to the
reporters steps to reproduce.

Once the filpicker gets loaded, the "Save" button says "undefined"; clicking it
throws this error in the JS console: 
Error: uncaught exception: [Exception... "Component returned failure code:
0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIFile.exists]"  nsresult: "0xc1f30001
(NS_ERROR_NOT_INITIALIZED)"  location: "JS frame ::
chrome://global/content/filepicker.js :: selectOnOK :: line 229"  data: no]

Also adding crash keyword, as clicking on certain elements of the UI will cause
a crash (Checking "Show hidden files and directories" seems to be a
reproduceable crash, though it isn't the only thing that causes crashes)
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-aviary1.0?
Keywords: crash
Also, "Save Link As" is *not* broken; the filepicker comes up, and downloads
work as they should.
yup, I see this as well: when I clicked the "Free Download" link, the filepicker
appears in either the same or new tab (depending on the pref I set). tested with
2004101109-0.9+ on fedora core 2. I get the following in the JS Console:

Error: this.mFilesEnumerator has no properties
Source File:
file:///home/sairuh/firefox-bits/2004101109-0.9+/firefox/components/nsFilePicker.js
Line: 88

as Neil points out in comment 3, this isn't a problem for the context menu
command, "save link as..." nor is it a problem when I save a page (ctrl+S) or
open a file (ctrl+O).
Keywords: regression
also see this when clicking a file uploading button in a form, such as the
"Browse" button used in the bugzilla's attachment form.
I think this is also causing the AdBlock filter dialog to break.  Instead of
showing a dialog with the URL to block, a new tab is opened now (on Windows).
I discussed this issue w/Asa, and he gave me the okay to add this to the
aviary1.0 blocker list: plussing.
Flags: blocking-aviary1.0? → blocking-aviary1.0+
Comment on attachment 162137 [details] [diff] [review]
make chrome URLs immune to tabbing

r+sr=jst
Attachment #162137 - Flags: superreview+
Attachment #162137 - Flags: review+
Attachment #162137 - Flags: approval-aviary?
Comment on attachment 162137 [details] [diff] [review]
make chrome URLs immune to tabbing

a=ben@mozilla.org
Attachment #162137 - Flags: approval-aviary? → approval-aviary+
Whiteboard: ready to land
Target Milestone: --- → Firefox1.0
Keywords: fixed-aviary1.0
Whiteboard: ready to land → trunk req: 172962
*** Bug 264723 has been marked as a duplicate of this bug. ***
vrfy'd fixed using 2004101809-0.9+ on linux fc2.
1. Should we put this in 1.7 to match Geckos?

2. Why is this bug still open?
Depends on: 172962
This patch isn't helpful in 1.7 (or on any branch) without the rest of single
window mode (bug 172962)

Fixed Trunk 1.8a6, Aviary/Firefox 1.0
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Whiteboard: trunk req: 172962
You need to log in before you can comment on or make changes to this bug.