bad authorization on http proxy if username contains cyrillic characters

VERIFIED DUPLICATE of bug 41489

Status

()

--
major
VERIFIED DUPLICATE of bug 41489
14 years ago
14 years ago

People

(Reporter: mothlike, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

Mozilla (tested in Mozilla 1.6, 1.7, Firefox 0.9-1.0PR) incorrectly send base64
encoded username (maybe password) to http proxy. I'am use sniffer to track this
and decode basic authorization header. He contains abracadabra, not my cyrillic
username and password! Latin names decodes correctly.

Reproducible: Always
Steps to Reproduce:
1. Enter cyrillic username and/or password on proxy.
Actual Results:  
Displays message "Invalid username or password"
(Reporter)

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 41489 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.