text field of bookmarkfolder gets editable if selected and expanded

RESOLVED FIXED in Camino1.0

Status

RESOLVED FIXED
15 years ago
14 years ago

People

(Reporter: florian, Assigned: sfraser_bugs)

Tracking

({fixed1.8})

unspecified
Camino1.0
PowerPC
macOS
fixed1.8

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a5) Gecko/20041011 Camino/0.8+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a5) Gecko/20041011 Camino/0.8+

Just switched from Safari to Camino, loved it and found the first bug:-)

If you select a bookmarkfolder and stay with the mousepointer over it the
bookmark textfield gets editable. That's normal.
But if you select a bookmarksfolder and expand the view so that the content gets
visible the bookmarks text field also gets visible. Even if you move the mouse
pointer away. I think thats a bug.
It doesn't happen if the bookmarks folder is not selected.

But i'm still in love :-)

Reproducible: Always
Steps to Reproduce:
1. Open Bookmarkmanager (Command + B)
2. Select the Bookmarks Bar or Menu
3. Click on a folder and move the mouse away. Nothing happens
4. Expand the folder by clicking on the triangle

Actual Results:  
-> The text field of the bookmarks folder gets editable


Expected Results:  
The bookmarks folder should stay selected but not become editable.
(Reporter)

Comment 1

15 years ago
This doesn't happen if the bookmarks folder is expanded via keys.

But it also happend in Camino 0.8.1.
*** Bug 264084 has been marked as a duplicate of this bug. ***

Comment 3

15 years ago
Confirming bug using 2004100808 (v0.8+) NB on 10.3.5

It's non destructive but a bit strange. The Finder doesn't have this issue in
list view. Apperently we are registring the secod click on the expand triangle
while we shouldn't do that.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: text field of bookmarkfolder gets editable if selected and expanded in bookmarks manager → text field of bookmarkfolder gets editable if selected and expanded
this has been around for a while, it'll be good to get it fixed but 1.0 is
prolly ok.
Target Milestone: --- → Camino1.0
(Assignee)

Comment 5

14 years ago
This bugs me.
Assignee: pinkerton → sfraser_bugs
bugs me too, just never got a chance to look at it.
(Assignee)

Comment 7

14 years ago
Created attachment 198962 [details] [diff] [review]
Patch

The bug was that [ExtendedOutlineView mouseDown:] was being too lax when
looking at the location of the click. This patch requires the click to be on
the text part of the cell.
(Assignee)

Comment 8

14 years ago
Created attachment 198963 [details] [diff] [review]
Patch

The bug was that [ExtendedOutlineView mouseDown:] was being too lax when
looking at the location of the click. This patch requires the click to be on
the text part of the cell.
(Assignee)

Comment 9

14 years ago
Sorry about the double attachment: bugzilla slowness.
Fixed on trunk and branch.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.