FF10PR1 crash [@ nsBookmarksService::OnUnassert]

RESOLVED DUPLICATE of bug 256622

Status

()

--
critical
RESOLVED DUPLICATE of bug 256622
14 years ago
8 years ago

People

(Reporter: jay, Assigned: vlad)

Tracking

({crash, helpwanted, topcrash})

1.0 Branch
x86
Windows XP
crash, helpwanted, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

14 years ago
Not too many user comments actually mention doing anything with bookmarks, but
from the stack, this crash is definitely somewhere in the bookmarks code.  Maybe
 bug 256622 can give us some clues on what is happening here?

Here is the latest from Talkback for PR1:

Count   Offset    Real Signature
[ 58   nsBookmarksService::OnUnassert 87d3be95 - nsBookmarksService::OnUnassert ]
[ 39   nsBookmarksService::OnUnassert 433f6896 - nsBookmarksService::OnUnassert ]
[ 11   nsBookmarksService::OnUnassert 9a9add92 - nsBookmarksService::OnUnassert ]
[ 10   nsBookmarksService::OnUnassert 6314e06b - nsBookmarksService::OnUnassert ]
 
     Crash date range: 02-OCT-04 to 07-OCT-04
     Min/Max Seconds since last crash: 22 - 965018
     Min/Max Runtime: 3980 - 1075954
 
     Count   Platform List 
     107   Windows XP [Windows NT 5.1 build 2600] 
     11   Windows 2K [Windows NT 5.0 build 2195] 
 
     Count   Build Id List 
     118   2004091322
 
     No of Unique Users       105
 
 Stack trace(Frame) 

	 nsBookmarksService::OnUnassert
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/browser/components/bookmarks/src/nsBookmarksService.cpp
 line 5480] 
	 InMemoryDataSource::Unassert
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/rdf/base/src/nsInMemoryDataSource.cpp
 line 1575] 
	 nsBookmarksService::Unassert
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/browser/components/bookmarks/src/nsBookmarksService.cpp
 line 3859] 
	 nsBookmarksService::UpdateLivemarkChildren
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/browser/components/bookmarks/src/nsBookmarksFeedHandler.cpp
 line 741] 
	 nsBookmarksService::GetTarget
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/browser/components/bookmarks/src/nsBookmarksService.cpp
 line 3709] 
	 CompositeDataSourceImpl::GetTarget
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/rdf/base/src/nsCompositeDataSource.cpp
 line 828] 
	 nsForwardProxyDataSource::GetTarget
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/browser/components/bookmarks/src/nsForwardProxyDataSource.cpp
 line 335] 
	 RDFContainerImpl::GetCount
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/rdf/base/src/nsRDFContainer.cpp
 line 204] 
	 nsRDFConInstanceTestNode::FilterInstantiations
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/content/xul/templates/src/nsRDFConInstanceTestNode.cpp
 line 165] 
	 TestNode::Propagate
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/content/xul/templates/src/nsRuleNetwork.cpp
 line 1046] 
	 TestNode::Propagate
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/content/xul/templates/src/nsRuleNetwork.cpp
 line 1054] 
	 TestNode::Propagate
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/content/xul/templates/src/nsRuleNetwork.cpp
 line 1054] 
	 TestNode::Propagate
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/content/xul/templates/src/nsRuleNetwork.cpp
 line 1054] 
	 RootNode::Propagate
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/content/xul/templates/src/nsRuleNetwork.cpp
 line 761] 
	 nsXULContentBuilder::CreateTemplateAndContainerContents
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp
 line 1150] 
	 nsXULContentBuilder::RebuildAll
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp
 line 1982] 
	 nsXULTemplateBuilder::Rebuild
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/content/xul/templates/src/nsXULTemplateBuilder.cpp
 line 240] 
	 nsXULDocument::AttributeChanged
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/content/xul/document/src/nsXULDocument.cpp
 line 1140] 
	 nsXULElement::SetAttrAndNotify
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/content/xul/content/src/nsXULElement.cpp
 line 2225] 
	 nsXULElement::SetAttr
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/content/xul/content/src/nsXULElement.cpp
 line 2148] 
	 nsXULElement::SetAttribute
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/content/xul/content/src/nsXULElement.cpp
 line 1022] 
	 nsXULElement::SetRef
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/content/xul/content/src/nsXULElement.cpp
 line 3696] 
	 XPTC_InvokeByIndex
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp
 line 102] 
	 XPCWrappedNative::CallMethod
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp
 line 2028] 
	 XPC_WN_GetterSetter
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp
 line 1311] 
	 js_Invoke
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/js/src/jsinterp.c 
line 941] 
	 js_InternalInvoke
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/js/src/jsinterp.c 
line 1035] 
	 js_InternalGetOrSet
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/js/src/jsinterp.c 
line 1078] 
	 js_SetProperty
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/js/src/jsobj.c  line
2849] 
	 js_Interpret
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/js/src/jsinterp.c 
line 2164] 
	 js_Invoke
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/js/src/jsinterp.c 
line 958] 
	 js_InternalInvoke
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/js/src/jsinterp.c 
line 1035] 
	 JS_CallFunctionValue
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/js/src/jsapi.c  line
3698] 
	 nsJSContext::CallEventHandler
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/dom/src/base/nsJSEnvironment.cpp
 line 1297] 
	 GlobalWindowImpl::RunTimeout
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/dom/src/base/nsGlobalWindow.cpp
 line 5083] 
	 GlobalWindowImpl::TimerCallback
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/dom/src/base/nsGlobalWindow.cpp
 line 5445] 
	 nsAppShellService::Run
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/xpfe/appshell/src/nsAppShellService.cpp
 line 495] 
	 main
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/browser/app/nsBrowserApp.cpp
 line 58] 
	 kernel32.dll + 0x16d4f (0x7c816d4f)   
 
     (1163791)	URL: www.priceline.com
     (1162478)	URL: www.geneology.com
     (1162478)	Comments: trying to build a family tree
     (1160937)	Comments: Researching Online on a Private password protected website
     (1160859)	Comments: Researching Online on a Private password protected website
     (1160070)	Comments: checking e-mail
     (1152406)	URL: www.canonusa.com
     (1152406)	Comments: clicked on a "file download" link on canon website- got
a message that a popup window was blocked  answered yes to allow popup window
fro www.canonusa.com. Then the browser shutdown
     (1149373)	URL: http://www.startribune.com
     (1149373)	Comments: Holding down control key and clicking on link to popup
window.  Tab for this window had already opened and I didn't see it yet.
     (1149282)	Comments: reading gmail - opening attached JPG pictures
     (1141618)	URL: http://www.w3schools.com    /    CSS Section
     (1138962)	URL: www.sears.com
     (1138962)	Comments: I was viewing a refridgerator model and clicked on the
"Exceptional value" link  then the browser crashed.
     (1126884)	URL: www.priceline.com
     (1125348)	URL: www.theskinfactory.com
     (1124598)	Comments: Auotmatically being switched from one site to another.
     (1122566)	Comments: clicking a link
     (1120633)	Comments: i was opening severall links similtaniously
     (1115945)	Comments: I was just searchin the web
     (1114447)	URL: www.sears.com
     (1114447)	Comments: researching compact refrigerators on sears.com
     (1109234)	Comments: I was opening a window to study for my Spanish test.
     (1108368)	URL: http://www.maxbo.no
     (1104359)	URL: http://www.gamebiz.com.au/news.php?action=display&id=4914
     (1104359)	Comments: checking out Halflife 2 screenshots
     (1098565)	Comments: I was on Yankees.com and tried to purchase postseason
tickets from ticketmaster.com in a popup window.
     (1096358)	URL: www.ennsdorf.at
     (1096358)	Comments: I was reading the news of this site and opened some
pictures of the "blumenschmuckaktion". Suddenly the browser crashed.
     (1096163)	Comments: Just browsing the net
     (1095933)	Comments: i was at nytimes.com
     (1091700)	URL: moneysupermarket.com
     (1091700)	Comments: Trying to find flight details to Nice  France using
their flight finder
     (1087138)	Comments: reading  deleting yahoo mail
     (1079571)	URL: www.scummvm.org
     (1078236)	URL: Aol.com
     (1078236)	Comments: Checking AOL mail
     (1077414)	Comments: home
 
====================================================================================================
     Count   Offset    Real Signature
[ 28   nsBookmarksService::OnUnassert 99a4b4a9 - nsBookmarksService::OnUnassert ]
 
     Crash date range: 02-OCT-04 to 07-OCT-04
     Min/Max Seconds since last crash: 2 - 343075
     Min/Max Runtime: 3251 - 869768
 
     Count   Platform List 
     14   Windows XP [Windows NT 5.1 build 2600] 
     8   Windows 98 [Windows 98 4.10 build 67766446] 
     3   Windows 2K [Windows NT 5.0 build 2195] 
     2   Windows ME [Windows 98 4.90 build 73010104] 
     1   Windows XP [Windows NT 5.2 build 3790] 
 
     Count   Build Id List 
     28   2004091322
 
     No of Unique Users        27
 
 Stack trace(Frame) 

	 nsBookmarksService::OnUnassert
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/browser/components/bookmarks/src/nsBookmarksService.cpp
 line 5480] 
	 InMemoryDataSource::Unassert
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/rdf/base/src/nsInMemoryDataSource.cpp
 line 1575] 
	 RDFContainerImpl::GetNextValue
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/rdf/base/src/nsRDFContainer.cpp
 line 746] 
	 RDFContainerImpl::AppendElement
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/rdf/base/src/nsRDFContainer.cpp
 line 254] 
	 nsFeedLoadListener::TryParseAsSimpleRSS
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/browser/components/bookmarks/src/nsBookmarksFeedHandler.cpp
 line 655] 
	 nsFeedLoadListener::OnStopRequest
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/browser/components/bookmarks/src/nsBookmarksFeedHandler.cpp
 line 253] 
	 nsStreamListenerTee::OnStopRequest
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/netwerk/base/src/nsStreamListenerTee.cpp
 line 65] 
	 nsInputStreamPump::OnStateStop
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Depend/mozilla/netwerk/base/src/nsInputStreamPump.cpp
 line 499]  
 
     (1114493)	Comments: signing off aol
     (1098290)	URL: www.icebergradio.com
     (1097484)	URL: indian-creek.net
     (1097484)	Comments: opening my browser
     (1097465)	URL: indian-creek.net
     (1089393)	URL: www.asia1.com.sg
     (1089393)	Comments: Starting MSN Messenger 6.2
     (1082760)	URL: www.bloglines.com

I have not been able to crash myself...but if we can figure out what's going on
from the stack, we should nominate for 1.0.  This is currently in the top 20 on
the PR1 topcrash list.
Jay, is this the same crash as bug 256622 ?

Status: NEW → ASSIGNED
(Reporter)

Comment 2

14 years ago
Vlad:  I don't think this bug is the same.  The stacks are fairly different and
it looks like bug 256622 was more about adding/refreshing a live bookmark, while
this one seems to be the result of opening a new window or tab while the live
bookmarks are busy trying to do something (maybe refresh)?
(In reply to comment #2)
> Vlad:  I don't think this bug is the same.  The stacks are fairly different and
> it looks like bug 256622 was more about adding/refreshing a live bookmark, while
> this one seems to be the result of opening a new window or tab while the live
> bookmarks are busy trying to do something (maybe refresh)?

Yeah, but it looks like the same type of crash -- something is removing itself
from the observers list from the OnUnassert callback.   I'm going to guess it's
fixed by 256622, until we see it on a nightly build..
(Reporter)

Comment 4

14 years ago
I don't see any of these crashes after the PR build 20041001xx in the latest
Talkback data.  I'm going to mark this a dup of bug 256622. Looks like that
checkin fixed this crash as well.  I'll just update that bug with 
nsBookmarksService::OnUnassert for tracking purposes.

*** This bug has been marked as a duplicate of 256622 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
Crash Signature: [@ nsBookmarksService::OnUnassert]
Crash Signature: [@ nsBookmarksService::OnUnassert]
You need to log in before you can comment on or make changes to this bug.