make Search Toolbar history easier to discover

NEW
Unassigned

Status

()

enhancement
P5
normal
Rank:
59
15 years ago
4 years ago

People

(Reporter: technical, Unassigned)

Tracking

({helpwanted})

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fxsearch])

Attachments

(2 attachments)

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

No Search History available from the Search Toolbar.. Unable to find the Search
history for any Search Engine used.

Reproducible: Always
Steps to Reproduce:
1. Enter several Search Strings into the Search tool bar
2. Try to recall any of the search strings entered from a history list
3.

Actual Results:  
No Search History available

Expected Results:  
Hold down and release the right mouse button in the search toolbar window and a
dropdown list of all previous searches would appear, or click in the Search
toolbar window for a list of all previous search strings, or someother method of
display search history until the history is cleared. The history should be
available across browser sessions.

Comment 1

15 years ago
The Search bar should have a search history like the location bar. It seems to
have "Clear search history" on the context menu but no actual history!

Requesting blocking - such a simple thing to fix and it would be very useful.
It's the sort of thing new users/reviewers will instantly notice and like
(hopefully).
Flags: blocking-aviary1.0?

Comment 2

15 years ago
I've just noticed that clear search history is actually for the search
autocomplete. Unlike a form autocomplete however you can't double-click on the
search bar to bring up the whole list.

To see this behaviour go to www.google.com and double click on the search field;
all your previous searches will appear. This could be implemented for the search
bar and might be a neater way of implementing this than having a permanently
displayed dropdown.

Comment 3

15 years ago
WFM. You have to either start typing in the search bar, or press the down arrow
key. For example, if you've searched for "mozilla" before, and you go to the
sarch bar again and press "m", a dropdown menu is displayed which contains
"mozilla".

Feel free to reopen if this doesn't work for you.
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Flags: blocking-aviary1.0?
Resolution: --- → WORKSFORME

Comment 4

15 years ago
I think this should be reopened as even though the search history does work (as
I mentioned in comment 2) it is not consistent with the form history - ie you
can't double-click on a blank search bar to bring up the search history.
Reporter

Comment 5

15 years ago
I cann't remember what I searched for in the past couple of weeks, so what do I
do, enter the alphabet a letter at a time until I come up with what I am looking
for.  It seems to me there should be a better way of recalling search history.
Maybe a combination of first letter or double clicking in the search box to
bring up the whole list. I don't agree with using the keyboard to get the whole
list. A mouse click or two should do it. 
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Re comment #5, please read comment #3. Just click on the searchbar and press the
down arrow key.
Reporter

Comment 7

15 years ago
Like I said, I don't agree with using the keyboard all the time. The mouse
should be also available.  Why should I have to use my keyboard at all,
shouldn't a mouse click do the same thing. Or is it too hard to implement?
(In reply to comment #3)
> WFM. You have to either start typing in the search bar, or press the down arrow
> key. For example, if you've searched for "mozilla" before, and you go to the
> sarch bar again and press "m", a dropdown menu is displayed which contains
> "mozilla".
> 
> Feel free to reopen if this doesn't work for you.

Comment 8

15 years ago
As per my previous comment (comment 4) why not make it like form history -
double-clicking on a blank search bar brings up the whole history. That said the
Location bar doesn't work this way.
Reporter

Comment 9

15 years ago
(In reply to comment #8)
> As per my previous comment (comment 4) why not make it like form history -
> double-clicking on a blank search bar brings up the whole history. That said the
> Location bar doesn't work this way.

I concur.. Why not!

Updated

15 years ago
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: No Search History in Search Toolbar → make Search Toolbar history easier to discover
*** Bug 269542 has been marked as a duplicate of this bug. ***

Comment 11

15 years ago
I think it should be combo box, like location bar. Only that way everyone will
be able to access this important feature.

Most users won't figure out down key (I knew it, but I saw many people asking
about, including in this bug). Also, many users won't figure out that they
should double-click for history (I didn't know it).

So there is just one solution that always works: combo box.
Assignee: p_ch → gavin.sharp
Target Milestone: --- → Firefox1.6-
Version: unspecified → Trunk
I'm not sure if this is something that should be exposed to all autocomplete
text boxes or just the search bar, with it's weird multiple dropdowns.
Status: NEW → ASSIGNED
Priority: -- → P5
This might happen as part of the new search service.
Target Milestone: Firefox 2 → Future
Assignee: gavin.sharp → nobody
Status: ASSIGNED → NEW
Keywords: helpwanted
Priority: P5 → --

Comment 14

12 years ago
This is an alternative approach, just add the pull-down arrow/combo box thing in the chrome with this.

Btw, forgive my ignorance, but how can I assign a bug to me?  Not sure how to change the "Assigned To" field
Attachment #260127 - Flags: review?

Comment 15

12 years ago
Oh, I also changed the maxrows to 20, which is a little more useful.  

My justification for the enablehistory="true" is that users shouldn't have to access the keyboard - in fact most of the time if I want to use an older search it's because i'm too lazy to type it in, so Firefox shouldn't force me to use the keyboard to get at my history.

And if you think it clutters up the UI - just do what I do: put the search bar into the menu between "Help" and the throbber...

Comment 16

12 years ago
Upon chatting with Gavin in IRC, he stated he didn't like the idea of the second patch.  Not sure of the exact reason, is it because of visual clutter?  What about the idea that the search history should be accessible via the mouse?
Attachment #260127 - Flags: review? → review?(rflint)
Attachment #260127 - Flags: review?(rflint) → ui-review?(faaborg)
for a quick ui-review Can you describe the behavior of the patch?  I'm not sure we really want to spend much time on the search bar since we may remove it from default UI by 4 with a more ubiquity-ish interface: https://wiki.mozilla.org/Firefox/Sprints/Windows_Theme_Revamp/Direction_and_Feedback
Comment on attachment 260127 [details] [diff] [review]
Alternative patch, just enablehistory in chrome

This increases the complexity of the UI, and searches (unlike Web navigation) are not as likely to be consistently repeated.  Unless of course the searches are navigational, in which case we already have a tool for that task.

The search interface should be based around recall, not recognition.
Attachment #260127 - Flags: ui-review?(faaborg) → ui-review-
Priority: -- → P5
Whiteboard: [fxsearch]

Updated

4 years ago
Rank: 59
You need to log in before you can comment on or make changes to this bug.