Can log in with all other browsers except Firefox 1.0PR

RESOLVED EXPIRED

Status

()

Firefox
General
--
minor
RESOLVED EXPIRED
13 years ago
12 years ago

People

(Reporter: Mike Gifford, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

Although it is reported to work in debian, it doesn't in Windows, Fedora2, or
MacOSX.

Here's the IRC discussion about it.

<mGiff>	Hello, after upgrading to firefox 1.0PR I can not log into the following
site http://cvs-demo.back-end.org/login.php (u: god p: password).  Works fine in
mozilla and earlier versions of firefox.  any ideas?
	<madduck>	works fine here.
	<CrazyFred>	doens't work for me, password field seems to blank early in submit
process
	<Peter6>	Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3)
Gecko/20041014 Firefox/0.10 doesn't work
	<CrazyFred>	I have 20041013
	<mGiff>	Thanks for testing this CrazyFred and Peter6..
	---	Peter6 is now known as Peter6_lunch
	<mGiff>	I've tested it with both a MacOSX and Fedora2 system..  Same problem..
	-->	chiefohio (~msieb@pD9E35A25.dip.t-dialin.net) has joined #firefox
	<--	chiefohio has quit (Client Quit)
	<madduck>	Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041003 Firefox/0.10.1
	<madduck>	here, thank me too.
	<mGiff>	CrazyFred could you check it in mozilla to verify that it is working
for you there..  Anyone have an earlier release of firefox about..
	<mGiff>	madduck - sorry..  Missed ya there..  :)  - Ok..  so why does it work
for you and nobody else..
	<madduck>	mGiff: yes. works fine in 0.9.3
	<madduck>	mGiff: cuz I run Debian? :)
	*	madduck struts
	<mGiff>	madduck - ya ya ya :) - but even in the Linux community Debian doesn't
have a great many users (even if it should)..
	<CrazyFred>	mGiff: Mozilla == ick ick, not installed. :-)
	<madduck>	mGiff: so? :_)
	<mGiff>	CrazyFred - any other browser then..  Heck, even opera..
	<madduck>	works fine in w3m/links/lynx/galeon
	<firebot>	New Firefox bug 264347 filed by janvbeek@planet.nl.
	<mGiff>	madduck - just that if it only works for firefox users who are using
debian, it's a bit of an uphill struggle..  and thanks for the others..  I
hadn't actually tried it in links or lynx before - cool..
	<CrazyFred>	mGiff: works ie 6 SP2
	-->	stephenhorlander (~stephen@12-220-204-73.client.insightBB.com) has joined
#firefox
	<mGiff>	CrazyFred - yeah..  So what is different with firefox 1.0PR??  Suppose
I should just file a bug report..


Reproducible: Always
Steps to Reproduce:
1.Go to the url above
2.sign in with u: god p: password
3.see the page reload with no new data

Actual Results:  
Basically the form isn't submitted from what I can tell..  

Expected Results:  
In all other browsers you can just log in and administer the site.

It doesn't crash, but it doesn't work either..  Kinda hard to promote this
otherwise great browser if you can't get it to work in the main product that we
produce..

If there's anything we need to do to adjust the code on the CMS we can do that
easily..  Just don't have any sense on where to begin.

Error: document.login has no properties
Source File: http://fis-server.openconcept.ca/login.php
Line: 145

Error: document.login has no properties
Source File: http://fis-server.openconcept.ca/login.php
Line: 78

There are these two javascript errors..  But it works everwhere else..  


Hmm..  Looks like it was a the javascript bugs then some other warning should be
produced.. or something.. 

I'll look into introducing 

Mike

Comment 1

13 years ago
Rather than using 
 document.login.response
with only works in IE, use
 document.forms['login'].getElementById['response']
Which is the standards way.
(Reporter)

Comment 2

13 years ago
thanks will implement a standards compliant version..  Still odd that firefox
1PR acts differently than all the rest though..

Mike
FF follows the rules and uses javascript (not M$-jscript).
Opera is compatible with a lot of IE-only script
IE, offcourse works, it's their script ;-)



(Reporter)

Comment 4

13 years ago
It isn't just opera, and IE where the script worked..  I've updated it now, but
even before then it worked in mozilla, galeon, lynx and if you follow the irc
thread a bunch of other browsers too.

But better to just make the javascript conform to standards...

Mike
(Reporter)

Comment 5

13 years ago
Ok..  The javascript now conforms to the standard and uses getElementById..  But
it still won't log in in Firefox 1.0PR even though it works everywhere else..

I'm about to make another release of this GPL project and would really like to
say it works with Firefox..  But so far that isn't the case..  

Have any other suggestions..  The javascript console is coming up clean on this
page..  

Strangely it does allow me to login/out on my localhost..

Mike

This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.