Mail Message Filters don't for Custom Headers

RESOLVED DUPLICATE of bug 184490

Status

MailNews Core
Filters
RESOLVED DUPLICATE of bug 184490
13 years ago
10 years ago

People

(Reporter: Jesse Molina, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040910


When using Mozilla 1.3 on Win23, using mail with a Microsoft Exchange IMAP
server, mail filtering does not always work as expected.

The problem focuses upon the observation that new mails are not filtered upon
receipt, when a custom header filter is used.  However, if the filters are run
manually, then filtering works okay.  This proves that the filter do correctly
ID the messages, but the filter is not being run at the right time, or not
identifying the messages upon initial receipt into the inbox.  Furthermore, at
least some non-Custom Header filters do work correctly and are filtered
immediately upon receipt.

The specific Custom Header that I am using is "list-post", which is then matched
with an eMail address.

The intent of what I am doing is to filter mail based upon Mailman mailing
lists.  The list-post header seems to be the best place to do this, but there
might be better.  None the less, the bug exists.

I also tested by using a specify string in the subject line and to do the same
action.  This rule, based upon a string in the subject of the message, was run
correctly.

Here is an excerpt from my message filter rule file, modified to protect
identity/me from getting fired;

--

name="list hostmaster@foobar.com"
enabled="yes"
type="1"
action="Move to folder"
actionValue="imap://Jesse.Molina@mailserver.foobar.com/INBOX/My_lists/hostmaster@foobar.com"
condition="OR (\"List-Post\",is,hostmaster@foobar.com)"

--



Reproducible: Always
Steps to Reproduce:
1. Create a new filter with a custom header to move a message into a folder
other than Inbox.
2. Receive a message which matches the filter.
3. The message will not have action taken against it by the filter, even though
it should have been.
4. Run mail filters manually, and the action will correctly be taken against the
message.

Actual Results:  
The message was filtered correctly, and the filters must be manually run against
the Inbox.

Expected Results:  
The message should have been filtered immediately upon receipt.  

Mail server is Microsoft Exchange 2003, using IMAP access.

Comment 1

13 years ago
Custom-header filtering for IMAP don't work, unfortunately.

*** This bug has been marked as a duplicate of 184490 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.