option "empty junk mail" for junk mail folder context menu

RESOLVED DUPLICATE of bug 189911

Status

SeaMonkey
MailNews: Message Display
--
enhancement
RESOLVED DUPLICATE of bug 189911
14 years ago
13 years ago

People

(Reporter: mandricus, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.1) Gecko/20040707
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.1) Gecko/20040707

i thinks that could be a little enhancement to put an "empty Junk Mail Folder"
option on right-click contextual menu on "Junk mail" folder . "Trash" folder
already have it, but since Junk mail folder it's intended for spam messages
only, why you have to trash it every time and then to empty your trash to
"destroy" that messages? Also, you do not have an option to trash all Junk Mail
folder messages, so you have every time to select all messages, drag it to the
trash (or press del key), then go to the trash, right click and select "empty
trash" to erase the spam messages. This could be very annoiyng if you receive
(like me :-((( ) a lot of spam.
Since spam is spam, i think that usually people simply wants to destroy these
irritating mails as soon as possible from their hard-disks. So i think that an
"empty junk mail folder" option, or in the worst case (if you want to give
people a "second chance" to retreive that messages from an accidental menu
choice) an "move junk mail to trash" option would be nice. And i think that it
would be very easy to implement :)

Bye and many thanks however for your very very great work (proud Mozilla User
since 1.2) ;-)

Mandricus.
  

Reproducible: Always
Steps to Reproduce:
1. move some message to "junk mail folder"
2. in the navigation tree on the left, right-click on "junk mail" folder
3. the contextual menu does not have the "move junk mail to trash" or "empty
junk mail folder" option.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 189911 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.