changing network.http.max-persistent-connections-per-server doesn't instant-apply.

RESOLVED DUPLICATE of bug 252118

Status

()

Core
Networking: HTTP
--
minor
RESOLVED DUPLICATE of bug 252118
14 years ago
14 years ago

People

(Reporter: Todd Berman, Assigned: Darin Fisher)

Tracking

Other Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20041013 Firefox/0.9.3 (Ubuntu)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20041013 Firefox/0.9.3 (Ubuntu)

When attempting to download 3 things at once from a server with
network.http.max-persistant-connections-per-server set to 2, I got the first 2
queued up, and then went and changed the pref to 5. I was unable to get a third
download going. Restarting firefox fixed the problem.

Reproducible: Always
Steps to Reproduce:
1. Set network.http.max-persistant-connections-per-server to 2
2. Queue up 2 downloads from one server.
3. Change the pref to allow 5
4. Attempt to get a 3rd download going.
Actual Results:  
No third download

Expected Results:  
Third download starts.
Spelling counts, moving to networking component.
Assignee: bugs → darin
Status: UNCONFIRMED → NEW
Component: Download Manager → Networking: HTTP
Ever confirmed: true
Product: Firefox → Browser
QA Contact: bmo → core.networking.http
Summary: changing network.http.max-persistant-connections-per-server doesn't instant-apply. → changing network.http.max-persistent-connections-per-server doesn't instant-apply.
Version: unspecified → Other Branch
fixed in bug  252118, update your firefox

*** This bug has been marked as a duplicate of 252118 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.