new items created above currently selected item, instead of below

RESOLVED INVALID

Status

()

RESOLVED INVALID
14 years ago
10 years ago

People

(Reporter: vlad, Unassigned)

Tracking

1.0 Branch
Future
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

This is a bug that's been filed before, but there was an attempted fix.  The
patch that'll be attached here is the bandaid that will ship with 1.0, that will
bring things back to the previously broken state -- bookmarks will be created
above the currently selected item, instead of below.

The reason for this is that we use the RDF Container InsertElementAt interface
here -- which, when given an index to insert at that's already occcupied, shifts
the old element forward, instead of putting this item after it.  This is a
bummer.  I tried to do some magic where the index was pre-incremented, but
InsertElementAt bails if you pass it an index that's greater than the number of
items in the container.   In either case, we have to know the item's exact
index, so that we can undo.  It's a huge pain in the ass.
Status: NEW → ASSIGNED
Target Milestone: --- → After Firefox 1.0
Created attachment 162236 [details] [diff] [review]
264571-bookmarks-bandaid-0.patch

The aforementioned bandaid.
Comment on attachment 162236 [details] [diff] [review]
264571-bookmarks-bandaid-0.patch

r+a=ben@mozilla.org
Attachment #162236 - Flags: review+
Attachment #162236 - Flags: approval-aviary+
when I paste an item, it also appears above the current selection. would that
also be fixed here, or is that expected behavior?

Comment 4

14 years ago
requesting blocking aviary 1.0 to get on radar to get the fix checked in.
Flags: blocking-aviary1.0?
My bad; this already went in, forgot to mark it.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Flags: blocking-aviary1.0?
Keywords: fixed-aviary1.0
Resolution: --- → FIXED
(In reply to comment #5)
> My bad; this already went in, forgot to mark it.

Vlad, when did the fix go in? I still see this issue in 2004102009-0.9+ when I
try to add a new item in the Bookmarks Manager and Sidebar (via context menu or
toolbar icon).

Sorry, i'm not thinking right; this bug still exists, and it was put back due to
the bandaid patch.. the patch doesn't fix the bug; the bug itself won't be fixed
until after 1.0..
Status: RESOLVED → REOPENED
Keywords: fixed-aviary1.0
Resolution: FIXED → ---

Comment 8

14 years ago
This bug seems to have an aviary branch checkin associated with it. If this has
landed on the aviary branch (as much as it's going to for 1.0) can you please
add the "fixed-aviary1.0" keyword? Thanks.
The patch isn't a fix, it actually introduces the problem described in this bug
(but fixes worse bugs in the process).
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
Assignee: vladimir → nobody
Status: REOPENED → NEW
design and code for 3.x is quite different, so this is invalid for 3.x, creating above is the default in all our views actually.
Status: NEW → RESOLVED
Last Resolved: 14 years ago10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.