Closed Bug 264583 Opened 15 years ago Closed 15 years ago

How do I list which users are in a group?

Categories

(Bugzilla :: Administration, task)

task
Not set

Tracking

()

RESOLVED FIXED
Bugzilla 2.20

People

(Reporter: harlan+bugzilla.com, Assigned: Wurblzap)

References

Details

(Whiteboard: [blocker will fix])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 Galeon/1.2.10 (X11; Linux i686; U;) Gecko/20030314
Build Identifier: Mozilla/5.0 Galeon/1.2.10 (X11; Linux i686; U;) Gecko/20030314

I was looking for a way to see which users were in a group.  From #irc I
discovered there is code to do this "late" in the stage of "delete a group".
I made another copy  of the code up higher...

Reproducible: Always
Steps to Reproduce:
1.
2.
3.




--- editgroups.cgi      Tue Apr 29 16:54:48 2003
+++ editgroups1.cgi     Fri Oct 15 03:33:30 2004
@@ -129,6 +129,8 @@
         print "<td><input type=\"checkbox\" name=\"isactive-$bit\" value=\"1\""
. ($isactive ? " checked" : "") . ">\n";
         print "<input type=hidden name=\"oldisactive-$bit\"
value=\"$isactive\"></td>\n";
         print "<td align=center valign=middle><a
href=\"editgroups.cgi?action=del&group=$bit\">Delete</a></td>\n";
+        print "<td align=center valign=middle><A
HREF=\"editusers.cgi?action=list&query=" .
+url_quote("(groupset & $bit) OR (blessgroupset & $bit)") . "\">List
Users</A></td>\n";
         print "</tr>\n";
     }

This is still kinda lame, but it is better than before (IMO).
This is covered by the patch in bug 119485.
Attached patch the patch...Splinter Review
It would probably be better to make this a subroutine and call it from the
two places that use it, but it is so lightweight...

Also, I wasn't sure if this was the best way to handle the extra column.
Depends on: 119485
Whiteboard: [blocker will fix]
Comment on attachment 162246 [details] [diff] [review]
the patch...

The patch doesn't apply to editusers.cgi any more since at least templatization
(bug 190222).
Attachment #162246 - Flags: review-
Fixed by bug 119485 :)
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Assignee: justdave → wurblzap
Status: UNCONFIRMED → NEW
Ever confirmed: true
Re-Resolving with the proper Assignee for the blocker that fixed it.
Status: NEW → RESOLVED
Closed: 15 years ago15 years ago
Resolution: --- → FIXED
Target Milestone: --- → Bugzilla 2.20
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.