wrong file permission when downloading without SHIFT

RESOLVED DUPLICATE of bug 124307

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 124307
13 years ago
13 years ago

People

(Reporter: bender2037, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

On the download page http://www.mozilla.org/products/firefox/ when just left
click on the download file
http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/0.10.1/firefox-1.0PR-i686-linux-gtk2+xft-installer.tar.gz
the choser opens asking 1. Open it with the default application (gzip) 2. Open
with ... 3. Save it to disk
I answer 3. Save it to disk.
After the download the file has permission 600.
If I just Shift and Left Click the link then mozilla sets permissions acording
my umask.
in my case umask 022 the permission is 644 

Reproducible: Always
Steps to Reproduce:
1. click the link without shift
2. see permission than rename or remove file
3. clich the same link with shift

Actual Results:  
the download menu ignores my umask

Expected Results:  
honorred umask
this is fixed in 1.7.x

*** This bug has been marked as a duplicate of 124307 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.