Manage Bookmarks creates new bookmark, even if "Cancel" is clicked.

RESOLVED DUPLICATE of bug 258821

Status

()

Firefox
Bookmarks & History
--
minor
RESOLVED DUPLICATE of bug 258821
13 years ago
11 years ago

People

(Reporter: David Craig, Assigned: vlad)

Tracking

1.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10

When using the "Manage Bookmarks" dialog, attempting to create a new bookmark
and then cancelling leaves an empty bookmark called 'New Bookmark'. The bookmark
appears in the main dialog window (as opposed to the small 'Properties for New
Bookmark' window) immediately when the user clicks File>New Bookmark (and before
any info is added).

Reproducible: Always
Steps to Reproduce:
1. In main browser window, click "Bookmarks>Manage Bookmarks"
2. In the new window (Bookmarks Manager) "File>New Bookmark..."
3. In the small new window (Properties for New Bookmark), click "Cancel" button

Actual Results:  
After step 2, a bookmark named "New Bookmark" appears in the Bookmarks Manager
window, in the 'root' of the bookmarks. After step 3, it is still there.

Expected Results:  
Presumably, the empty bookmark should disappear.

I have only tried this on the Linux (Fedora Core 2) build, have not confirmed
with windows.

*** This bug has been marked as a duplicate of 258821 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

13 years ago
Version: unspecified → 1.0 Branch
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.