wrong scroll position for an anchor within a table

RESOLVED DUPLICATE of bug 60307

Status

()

defect
--
minor
RESOLVED DUPLICATE of bug 60307
15 years ago
15 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a5) Gecko/20041020 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a5) Gecko/20041020 Firefox/0.9.1+

If I follow a link that contains an anchor which is to be found in a nested
table, it is displayed outside the view area.

It happens only if I click this link for the first time.
If I go back and click the link again, it stays in the right position,
as well as if I enter the target URL directly.


Reproducible: Sometimes
Steps to Reproduce:
1. http://karlsruhe.feg.de/
2. Click "Samstag, 6. November" near the flag (it is the link
http://karlsruhe.feg.de/myfeg/index.php?html_seite=14#20041106 ).


Actual Results:  
The subsequent page appeared in the right position, but only for a short time -
then it scrolled down one table row, which makes the anchor position disappear.

Expected Results:  
Show the desired table row, described by the anchor, within the view area - and
stay there.

The page also contains an auto-scrolling menu, maybe it has to do with that.
This happens because the images are still loading after the position to the
anchor has been set. They cause the content above the anchor to grow, and that
pushes the content down below the images.
It is a duplicate of bug 60307.

*** This bug has been marked as a duplicate of 60307 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Hm, are You sure?
As you say, if the images grow, the content below the images should move down,
causing the anchor to be somewhere in the area, instead on top (or in the worst
case disappear behind the bottom border).
But in my case, the visible part moves UP, disappearing behing the top of the
visible area! (Sorry if I have expressed it wrong, with scrolling down I meant
that the content moves up). This would mean that something has shrunk there?
And the following table row seems perfectly aligned to the top of the window.
Oops! Yes, you're right. However, I still think it is a duplicate.

When the image in a document is not loaded yet, the placeholder is showed
(broken image). This has width:24px and height:24px.
A lot of the images on the URL testcase have a height of 18px or 20px which is
shorter than the placeholder.
So the same effect is happening, but in the reverse direction (upwards, not
downwards).
You need to log in before you can comment on or make changes to this bug.