Hebrew Textarea Editing Misbehaves

VERIFIED DUPLICATE of bug 207186

Status

()

VERIFIED DUPLICATE of bug 207186
14 years ago
14 years ago

People

(Reporter: shlomif, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10

When using the Hebrew Textarea editor if one presses the end key in a Hebrew
line, and then presses the up button and down button, the cursor jumps to the
end or the top of the document. 

Furthermore, at the end of the edited text, if one presses the up button a few
times, then the cursor jumps to the beginning of the document.

Reproducible: Always
Steps to Reproduce:
1. Go to the URL.
2. Make the text area active.
3. Position the cursor in the middle of the text.
4. Type something in Hebrew.
5. Press the end key.
6. Press the up key.
7. Press the down key.

Or alternatively:

1. Go to the end of the document.

2. Press the up key a few times.

Actual Results:  
The cursor jumps to the start or beginning of the document.

Expected Results:  
The cursor should have stayed where it is.
Duplicate of one of the issues covered by bug 207186 (bug 207186 comment #2).

*** This bug has been marked as a duplicate of 207186 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.