Closed Bug 265658 Opened 16 years ago Closed 16 years ago

Eudora and Mac OSX Mail.app users can't see text attachment as attachment

Categories

(MailNews Core :: MIME, defect)

1.7 Branch
x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 66915

People

(Reporter: baffoni, Assigned: sspitzer)

Details

When I send an attached text file in and email to Mac Eudora and Mac OSX
Mail.app users, they only see the email as part of the message body, they don't
see it as an attachment.  They see it properly if they send the same attachment
to themselves or to each other (OSX Mail and Eudora reach each others the same
way).  I see my own text attachment as an attachment if I send it to myself, or
if they send it to me.

The only thing I can see different in the way that the MIME attachment is
constructed is that in the Eudora/Mail app MIME construction, they declare the
attachment like this:

Content-Type: text/plain; name="texttest.txt"; charset="us-ascii" ; format="flowed"
Content-Disposition: attachment; filename="texttest.txt"
 ; modification-date="Wed, 20 Oct 2004 17:08:56 -0700"

and Mozilla declares it like this:

Content-Type: text/plain;
 name="test.txt"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline;
 filename="test.txt"

Since Mozilla can properly see the attachment in the body if it is set to view
inline, is there anyway that we can set attachments to "attachment;" rather than
"inline'" by default (or is there some other issue here)?

*** This bug has been marked as a duplicate of 66915 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.