Closed Bug 265707 Opened 16 years ago Closed 16 years ago

SECMOD_FindSlot always returns NULL

Categories

(NSS :: Libraries, defect, P1)

3.9.3
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: julien.pierre, Assigned: julien.pierre)

Details

(Keywords: regression)

Attachments

(1 file)

The end of this function reads as :
    return NULL;
    return retSlot;
}

This is the only return path . I believe the "return retSlot" is intended.
Priority: -- → P2
Target Milestone: --- → 3.9.4
Assignee: wchang0222 → julien.pierre.bugs
Status: NEW → ASSIGNED
Keywords: sun-orion3
This is a bug where we may need to be bug compatible.
This bug means the body of this function is essentially
never exercised, so its result may be incorrect.  Also,
the fix may cause code paths in NSS clients that have
never been tested before, to be taken.  So, the fix must
be carefully reviewed, and some key NSS clients need
to be examined to see how they use this function.
In other words, we may not want to fix this bug in
a patch release.
Wan-Teh,

I believe this is a regression, even though I don't exactly know when it was
introduced yet. On the SUN_NSS_3_3_BRANCH, this function can return a value
other than NULL.
Actually, this is a regression introduced since NSS_3_9_2_RTM . I didn't find a
tag for the 3.9.3 rtm that you made last week, but I would guess it happened
between 3.9.2 and 3.9.3 .
Priority: P2 → P1
Comment on attachment 163095 [details] [diff] [review]
remove bogus return NULL statement

r=wtc.
Attachment #163095 - Flags: superreview?(rrelyea0264)
Attachment #163095 - Flags: review+
Wan-Teh, thanks for the review. I have checked in the fix to NSS_3_9_BRANCH,
since we are building 3.9.4 very soon. I will check in the fix to the tip after
Bob's review.

Checking in pk11util.c;
/cvsroot/mozilla/security/nss/lib/pk11wrap/pk11util.c,v  <--  pk11util.c
new revision: 1.41.16.2; previous revision: 1.41.16.1

Comment on attachment 163095 [details] [diff] [review]
remove bogus return NULL statement

r=relyea
Attachment #163095 - Flags: superreview?(rrelyea0264) → superreview+
Thanks, Bob ! I checked in the patch to the tip .

Checking in pk11util.c;
/cvsroot/mozilla/security/nss/lib/pk11wrap/pk11util.c,v  <--  pk11util.c
new revision: 1.46; previous revision: 1.45
done
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Requesting aviary 1.0 and mozilla 1.7 branch approval.
This bug is introduced in the NSS 3.9.3 release that
these two branches recently upgraded to.  The fix is
very simple.
Flags: blocking1.7.x?
Flags: blocking-aviary1.0?
Keywords: regression
Please use the 'approval-aviary?' and 'approval1.7.x?' flags to request approval
(attachment->edit).
Attachment #163095 - Flags: approval1.7.x?
Attachment #163095 - Flags: approval-aviary?
Comment on attachment 163095 [details] [diff] [review]
remove bogus return NULL statement

Please get this into aviary quickly.
Attachment #163095 - Flags: approval1.7.x?
Attachment #163095 - Flags: approval1.7.x+
Attachment #163095 - Flags: approval-aviary?
Attachment #163095 - Flags: approval-aviary+
Comment on attachment 163095 [details] [diff] [review]
remove bogus return NULL statement

Requesting aviary 1.0 checkin again.
Attachment #163095 - Flags: approval-aviary+ → approval-aviary?
Comment on attachment 163095 [details] [diff] [review]
remove bogus return NULL statement

a=asa for branch checkin. Time is short so please land quickly.
Attachment #163095 - Flags: approval-aviary? → approval-aviary+
Comment on attachment 163095 [details] [diff] [review]
remove bogus return NULL statement

I checked in this fix on the AVIARY_1_0_20040515_BRANCH
(Firefox 1.0).

Checking in pk11util.c;
/cvsroot/mozilla/security/nss/lib/pk11wrap/pk11util.c,v  <--  pk11util.c
new revision: 1.41.22.2; previous revision: 1.41.22.1
done
Flags: blocking1.7.x?
Flags: blocking-aviary1.0?
You need to log in before you can comment on or make changes to this bug.