Status

()

defect
--
critical
RESOLVED INVALID
15 years ago
13 years ago

People

(Reporter: pavel.penaz, Assigned: bugzilla)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041024 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041024 Firefox/1.0

Firefox freezes when parsing invalid HTML. I came across this bug using the
mangle.cgi script. I'll attach a testcase in a minute. 

Reproducible: Always
Steps to Reproduce:
(Reporter)

Comment 1

15 years ago
(Reporter)

Updated

15 years ago
Attachment #163245 - Attachment description: cause Firefox to freeze → testcase (causes Firefox to freeze)
(Reporter)

Updated

15 years ago
Attachment #163245 - Attachment description: testcase (causes Firefox to freeze) → testcase (makes Firefox freeze)
(Reporter)

Comment 2

15 years ago
-> blocking 264944
Blocks: Zalewski
(Reporter)

Comment 3

15 years ago

Comment 4

15 years ago
The "freezeng" testcase WFM with both fresh trunk and 1.7.x builds (20041024) on
Windows ME.

Most probably it was fixed by the mozilla_die1 fix for bug 264956. 

I'm not marking WORKSFORME yet, until someone using WinXP confirms WFM.

Comment 5

15 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.3) Gecko/20041024 Firefox/1.0
Java(TM) 2 Platform Standard Edition 5.0
Java Plug-in 1.5.0

The Java Console is showing:

java.net.MalformedURLException: unknown protocol: mk
	at java.net.URL.<init>(Unknown Source)
	at java.net.URL.<init>(Unknown Source)
	at java.net.URL.<init>(Unknown Source)
	at sun.plugin.AppletViewer.setDocumentBase(Unknown Source)
	at sun.plugin.viewer.WNetscapePluginObject.setDocumentURL(Unknown Source)


Reporter, do you use the latest Java? Do you use extensions?

Comment 6

15 years ago
WFM with Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7.3) Gecko/20041024
Firefox/1.0.
Java 1.4.2_06, Windows ME.

I'm not the reporter but I strongly doubt this is a Java bug.
(Reporter)

Comment 7

15 years ago
Oops sorry, I didn't try this with a new profile. It seems Adblock is
responsible for this freeze, with Adblock disabled the testcase does not crash.

Comment 8

15 years ago
OK. Marking then as INVALID per comment 7 by the reporter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 9

15 years ago
Adblock exposes a Java bug that is fixed in Java 1.5.0 that causes hangs.

Comment 10

15 years ago
Robert: I have Java 1.4.2_06 and no hang on three new different mozilla.org
products.

Comment 11

15 years ago
I'm not saying that was for the cause, but Adblock does expose some Java bugs
you don't normally see that were fixed in 1.5.0.

Comment 12

15 years ago
OK. So maybe they were fixed in 1.4.2_06, too. Butbthat still does not make it a
mozilla.org bug.

Updated

15 years ago
Keywords: hang
You need to log in before you can comment on or make changes to this bug.