Crashes when loading web page, running on a thin client. Can be reproduced every time

RESOLVED DUPLICATE of bug 114152

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 114152
13 years ago
4 years ago

People

(Reporter: abrodsky, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041012 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041012 Firefox/0.10

When loading above URL firefox crashes every time and yields the following
error message.

 INTERNAL ERROR on Browser End: Exec of "java_vm" failed: 2
<
System error?:: No such file or directory
Gdk-ERROR **: Fatal IO error 9 (Bad file descriptor) on X server
ncd33.theory.toronto.edu:0.0.
INTERNAL ERROR on Browser End: Could not read ack from child process
System error?:: Resource temporarily unavailable



Reproducible: Always
Steps to Reproduce:
1. firefox &
2. <ctrl>-l  
3. www.ttc.ca

<CRASH>
Actual Results:  
INTERNAL ERROR on Browser End: Exec of "java_vm" failed: 2
<
System error?:: No such file or directory
Gdk-ERROR **: Fatal IO error 9 (Bad file descriptor) on X server
ncd33.theory.toronto.edu:0.0.
INTERNAL ERROR on Browser End: Could not read ack from child process
System error?:: Resource temporarily unavailable

Expected Results:  
Display the page?

I am running on a thin client, using a remote Linux server.  This bug does not
occur under Solaris, but does occur under Linux.  Reproducible on both a NCD
colour X-term and a Sun-Ray.

Comment 1

13 years ago
we already have bugs about NCD and Sun-Rays, please browse through those first.
Whiteboard: DUPEME

Comment 2

13 years ago
I could find no currently exiting bugs concerning NCD, Sun Ray or Thin Clients
relating to Firefox.  Can this be marked resolved or can DUPEME be removed from
the whiteboard?

Comment 3

13 years ago
did i specify firefox? this is a gecko problem. search through the other products.

Comment 4

13 years ago
On the offending page I found:
"		<applet codebase="http://www.toronto.ca/ttc/" code="LScrollText.class"
width="590" height="18" >
						<PARAM NAME="MESSAGE" VALUE="Maps and Schedules of all TTC Routes are
Available On-line  . . . 
						 Has Your Route Changed ? See 'Recent Service Changes' to find out  . . .">
						<PARAM NAME="FONTHEIGHT" VALUE="14">
						<PARAM NAME="SPEED" VALUE="24">
						<PARAM NAME="PIXELS" VALUE="2">
						<PARAM NAME="FONTCOLOR" VALUE="FFE500">
						<PARAM NAME="BACKCOLOR" VALUE="000000">
						</applet>"

This code would cause Java to try to instalize, we have a bug on that, bug
114152.  Also note the error that bug gave: 

"swa@abruzzo:~ > mozilla
ProfileManager : StartApprunner
profileName passed in: swa
INTERNAL ERROR on Browser End: Exec of "java_vm" failed: 2
<
System error?:: No such file or directory
Gdk-ERROR **: Fatal IO error 9 (Bad file descriptor) on X server :0.0.
INTERNAL ERROR on Browser End: Could not read ack from browser
System error?:: Resource temporarily unavailable
swa@abruzzo:~ >"

Duping...

*** This bug has been marked as a duplicate of 114152 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.