The default bug view has changed. See this FAQ.

[BEOS] Saving internal files with nsLocalFileUnix::CreateUnique fails because of missing check for NS_EXCL in bfile.c

RESOLVED FIXED in 4.6

Status

NSPR
NSPR
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: tqh, Assigned: Niels Reedijk)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (BeOS; U; BeOS BePC; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0
Build Identifier: Mozilla/5.0 (BeOS; U; BeOS BePC; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0

Recent builds on BeOS after 0.93 complains when trying to save preferences with
the 'Can't save preferences'.. error message, but the changes are saved. 

It doesn't matter if it's a new profile. It has popped up with all people that
tried a recent build.

Reproducible: Always
Steps to Reproduce:
1. Open preferences
2. Change values
3. Close preferences

Actual Results:  
'Can't save preferences'-message shows up, but prefs are saved.

Expected Results:  
prefs are saved.
(Reporter)

Updated

13 years ago
Blocks: 266252
Assignee: firefox → Niels.Reedijk
(Assignee)

Comment 1

13 years ago
Created attachment 165205 [details] [diff] [review]
The patch

This patch fixes bug 266327 and 266328 . And it keeps firefox from spilling out
a lot of information on cookies that are probably lost (which aren't).
(Assignee)

Comment 2

13 years ago
Changed the summary and component of the bug. Bug 266328 is in fact a dupicate
of this one. 
Status: NEW → ASSIGNED
Component: Preferences → NSPR
Product: Firefox → NSPR
Summary: [BEOS] Closing preferences complains that preferences can't be saved (but they are). → [BEOS] Saving internal files with nsLocalFileUnix::CreateUnique fails because of missing check for NS_EXCL in bfile.c
Version: unspecified → 3.0
(Assignee)

Comment 3

13 years ago
*** Bug 266328 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

13 years ago
Attachment #165205 - Flags: superreview?(thesuckiestemail)
Attachment #165205 - Flags: review?(simontaylor2)

Comment 4

13 years ago
Comment on attachment 165205 [details] [diff] [review]
The patch

Looks good to me.

Sometimes it's easier to get checkin if you only change the needed bit - ie
just add the one case needed and remove the formatting changes. But I'll give
it a review anyway.

I'm not sure of the process we have to follow to get something checked into
NSPR.
Attachment #165205 - Flags: review?(simontaylor2) → review+

Comment 5

13 years ago
Comment on attachment 165205 [details] [diff] [review]
The patch

Forgot to add
r=simontaylor2@gawab.com to the above comment
(Assignee)

Comment 6

13 years ago
Comment on attachment 165205 [details] [diff] [review]
The patch

Asking super-review from the NSPR module owner. This is a BeOS only-change and
will not affect other platforms in any way. The patch does touch some
formatting, but not the functionality of those lines. It ends up being
identical to unix.c (in regards to the flag checking)
Attachment #165205 - Flags: superreview?(thesuckiestemail) → superreview?(wchang0222)

Updated

13 years ago
Attachment #165205 - Flags: superreview?(wchang0222) → superreview+

Comment 7

13 years ago
I checked in this fix on the NSPR trunk (NSPR 4.6).

Checking in bfile.c;
/cvsroot/mozilla/nsprpub/pr/src/md/beos/bfile.c,v  <--  bfile.c
new revision: 3.13; previous revision: 3.12
done

I will check it in on the NSPRPUB_PRE_4_5_CLIENT_BRANCH
when the code freeze on the SeaMonkey trunk is over.
If this fix is urgent you can request drivers' approval.
Target Milestone: --- → 4.6
(Assignee)

Comment 8

13 years ago
Comment on attachment 165205 [details] [diff] [review]
The patch

Even though it is not urgent, I just want this bug to be fully fixed
everywhere. This is a BeOS only change, and, as before, will not touch anything
other than beos files.
Attachment #165205 - Flags: approval1.8a5?
(Assignee)

Updated

13 years ago
Attachment #165205 - Flags: approval-aviary?

Updated

13 years ago
Attachment #165205 - Flags: approval1.8a5?

Updated

13 years ago
Attachment #165205 - Flags: approval-aviary? → approval-aviary-

Comment 9

13 years ago
I checked in the patch on the NSPRPUB_PRE_4_2_CLIENT_BRANCH
(post Mozilla 1.8 Alpha 5).
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.