Closed Bug 266377 Opened 16 years ago Closed 16 years ago

Javascript mouseover fails to terminate when scrollwheel is used

Categories

(Firefox :: General, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 50511

People

(Reporter: liquid_net, Assigned: bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1

We are using a slightly modified version of the DOM Tooltip code found at
http://www.mojavelinux.com/forum/viewtopic.php?t=127 for our open source
web-calendaring project called Kronophobia.  There seems to be a persistent bug
in Firefox that causes it to not terminate the mouseover when the scrollwheel is
used to move the page up or down.  The result is that the mouseover text is left
on the page and keeps accumulating the more links you mouseover.  I have
installed multiple versions of Firefox and found that some of the nightly
packages in 08 trunk lines and such DID work correctly so I am confused as to
whether the bugfix is just not being propagated or what?

Reproducible: Always
Steps to Reproduce:
1. Put mouse cursor over a calendar event and wait for mouseover
2. Use scrollwheel to scroll the page down
3. Mouseover stays open

Actual Results:  
The result is that the mouseover text is left on the page and keeps accumulating
the more links you mouseover.

Expected Results:  
The mouseover should vanish.  Internet Explorer, certain versions of Mozilla,
certain versions of Firefox, Opera, Konqueror, etc all handle this correctly.

*** This bug has been marked as a duplicate of 20022 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 50511 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.