Closed Bug 266448 Opened 16 years ago Closed 16 years ago

line breaks inside tilte attributes (tooltips) using "
"

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 67127

People

(Reporter: mark_fierling, Assigned: bugzilla)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

there seems to currently be no way to display a line break inside a title
attribute. this is useful when wanting to display multi-line details for an
image or hyperlink.

example html:
<a href="myfile.doc" title="Type: Microsoft Word Document &#10;Date Modified:
02/27/04 3:21pm &#10;Size: 97KB">myfile.doc</a>

in IE this the resulting tooltip looks like this:
-------------------------------
Type: Microsoft Word Document
Date Modified: 02/27/04 3:21pm
Size: 97KB
-------------------------------

firefox renders it like this:
-------------------------------
Type: Microsoft Word Document |Date Modified: 02/27/04 3:21pm |Size: 97KB
-------------------------------

in IE, using &#10; and actual source line break work and result in a tooltip
line break. (try this: <a href="test.htm" title="'&amp;#10' line break&#10;
'&lt;br&gt;' line break<br> 'actual source' line break
end">test.htm</a>)

i think FF should support the &#10; method as it is the most likely behaviour
expected by webdesigners having this string in their title attribute and thus
wouldn't break anything.

cheers,
mark

Reproducible: Always
Steps to Reproduce:
1. create html page and paste the above samples in the body
2. load html page
3. observe

Actual Results:  
tooltip looking like:
-------------------------------
Type: Microsoft Word Document |Date Modified: 02/27/04 3:21pm |Size: 97KB
-------------------------------

Expected Results:  
tooltip looking like:
-------------------------------
Type: Microsoft Word Document
Date Modified: 02/27/04 3:21pm
Size: 97KB
-------------------------------
Attached file html testpage
Summary: line breaks inside tilte attributes (tooltips) using "&#50;" → line breaks inside tilte attributes (tooltips) using "&#10;"

*** This bug has been marked as a duplicate of 67127 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.