Closed Bug 266706 Opened 19 years ago Closed 19 years ago

hyphen with number on wrong place when downloading multiple files of same name

Categories

(Toolkit :: Downloads API, defect)

x86
Windows XP
defect
Not set
minor

Tracking

()

VERIFIED DUPLICATE of bug 231048

People

(Reporter: bugzilla, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

In Download Manager when you successfully download a file whose name contains a
dot in the file name other than the one on the end which denotes the begin of
the file extension, and after try to download another file of the same name (or
even the same file once more), the feature which adds "-1" in order to
distinguish between the two downloaded copies behave wrong, since the "-1" gets
inserted just before the first dot (within the file name), while it should be
inserted rather in front of the last dot (i.e. before the file name extension).

Reproducible: Always
Steps to Reproduce:
1. Download a file whose name includes a dot (but not counting in the one which
denotes the begin of the file name extension)
2. Launch download of a file of the same name, or even of the same file once more.

Actual Results:  
Characters "-1" used to distinguish between the two downloaded copies gets
inserted just before the first dot (that one still within the file name).

Expected Results:  
Characters "-1" should get inserted rather in front of the last dot (i.e. before
the file name extension).

*** This bug has been marked as a duplicate of 231048 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.