Disable Single Window Mode by default for 1.0

VERIFIED FIXED

Status

()

Firefox
Tabbed Browser
VERIFIED FIXED
13 years ago
9 years ago

People

(Reporter: Ben Goodger (use ben at mozilla dot org for email), Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({fixed-aviary1.0})

unspecified
fixed-aviary1.0
Points:
---
Bug Flags:
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

There are recurring crashes related to single window mode in Firefox... we're
not having an easy time reproducing them and there are numerous issues
(window.close not working right etc)... as a result we've decided to disable the
UI that lets you set single window mode preferences for Firefox 1.0...

the disabling is being done off a pref, browser.tabs.showSingleWindowModePrefs,
which when set to true via about:config will show the UI again.
Created attachment 163887 [details] [diff] [review]
patch to disable UI based on a pref
Comment on attachment 163887 [details] [diff] [review]
patch to disable UI based on a pref

+  // XXXben - Hide Single Window mode prefs for 1.0
+  var tabbedOpenForce = document.getElementById("tabbedOpenForce");
+  var tabbedWindowLinks = document.getElementById("tabbedWindowLinks");
+  if (parent.hPrefWindow.getPref("bool",
"browser.tabs.showSingleWindowModePrefs", false)) {
+    tabbedOpenForce.hidden = false;
+    tabbedWindowLinks.hidden = false;
+  }

You could declare the two local variables inside the if check since they're not
used outside of it.

sr=jst either way tho.
Attachment #163887 - Flags: superreview+
Created attachment 163890 [details] [diff] [review]
patch

consolidate.
Attachment #163887 - Attachment is obsolete: true

Comment 4

13 years ago
Comment on attachment 163890 [details] [diff] [review]
patch

a=asa for aviary checkin.
Attachment #163890 - Flags: approval-aviary+
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Flags: blocking-aviary1.0+
Resolution: --- → FIXED

Updated

13 years ago
Keywords: fixed-aviary1.0
yup, the UI is hidden: vrfy'd fixed with 200411030x-0.11 on linux fc2 and mac os
x 10.3.5.
Status: RESOLVED → VERIFIED

Comment 6

13 years ago
It's not disabled for me and I like it not being disabled.

Comment 7

13 years ago
@fantasai: Shouldn't that be re-enabled on the trunk (eg for crash testing!)? It
is disabled now since the aviary branch landing.
You need to log in before you can comment on or make changes to this bug.