[Mac only] software update test doesn't work

RESOLVED INVALID

Status

()

Toolkit
Application Update
--
critical
RESOLVED INVALID
13 years ago
6 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

1.7 Branch
mozilla1.8final
PowerPC
Mac OS X
Points:
---
Bug Flags:
blocking-aviary1.0 -
blocking-aviary1.5 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: update was disabled for 1.0, URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
the software update test at
http://www.mozilla.org/projects/firefox/qa/softwareupdate.html to upgrade from
1.0PR to 1.0RC1 doesn't work. Ben suggests removing the UI for this aspect for
1.0final.

1. launch 1.0PR

2. go to about:config and change the default of the app.update.url pref to
http://update.mozilla.org/update/firefox/en-US-1.0-rc.rdf

3. go to Preferences > Advanced > Software Update and click the "Check Now" button.

4. in the resulting software update wizard, go ahead and select the upgrade to
1.0RC1 (it doesn't matter whether or not you select to get talkback or the web
development tools).

expect: the wizard should download and install the upgrade, prompt you to
restart firefox, etc.

actual results: very quickly get the "install completed" panel in the wizard
--but no upgrade or installation had occurred (still remains 1.0PR).
(Reporter)

Comment 1

13 years ago
blocking-aviary1.0, per Asa.
Flags: blocking-aviary1.0+
Version: unspecified → 1.0 Branch
Created attachment 164062 [details] [diff] [review]
patch

don't build app update info for mac... theoretically patching and extension
update still all work!
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Keywords: fixed-aviary1.0
Using Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5)
Gecko/20041103 Firefox/1.0RC2, I still see the UI come up. It says updates are
found, then you get a blank screen with the "Install" button enabled. If you
happen to click on the Install button you get stuck in a loop and have to
force-quit.

Reopening, I mentioned this to Ben yesterday.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Keywords: fixed-aviary1.0

Updated

13 years ago
Whiteboard: aka disable mac software update
Not catastrophic, not going to block. 
Flags: blocking-aviary1.0+ → blocking-aviary1.0-
*** Bug 267742 has been marked as a duplicate of this bug. ***
*** Bug 275774 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

13 years ago
Flags: blocking-aviary1.1?
Flags: blocking-aviary1.1? → blocking-aviary1.1+

Updated

13 years ago
Whiteboard: aka disable mac software update → [asaP1] update was disabled for 1.0

Comment 7

13 years ago
In version 1.0.2 checking (check now) for software updates seems not to find
version 1.0.3 (mac os 10.3.9)

Updated

13 years ago
Flags: blocking-aviary1.1+ → blocking-aviary1.1-

Updated

12 years ago
Whiteboard: [asaP1] update was disabled for 1.0 → update was disabled for 1.0
The old SWU implementation is gone, closing as INVALID.
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → INVALID
Target Milestone: --- → Firefox1.5
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.