using DDE and WWW_OpenURL to open a file results in a truncated file name

RESOLVED DUPLICATE of bug 255196

Status

()

RESOLVED DUPLICATE of bug 255196
14 years ago
14 years ago

People

(Reporter: firefox_97, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

I am using labview to open a html file in the default browser.  It has a canned
DDE call using WWW_OpenURL.  This works fine in IE, but in Firefox it truncates
the URL.  If no browser is open it will only open a blank page, and if a window
is open, it will say that the file ...htm could not be found.  It seems to trim
off the last character.  If I try to open a .htm file it will report that it
tried to open a .ht file and failed.  It seems to report the error twice.

Reproducible: Always
Steps to Reproduce:
1.Send DDE WWW_OpenURL to Firefox
2.send url with .html
3.browser will report no .htm file found.

Actual Results:  
error box will open saying the file could not be found.

Expected Results:  
it should have opened the .html file as the url was sent.

Comment 1

14 years ago
Formally confirming
It's a the same as bug 255196 for Mozilla trunk. It seems that Firefox needs line
http://lxr.mozilla.org/aviarybranch/source/toolkit/xre/nsNativeAppSupportWin.cpp#1151
to be changed (change length parameter according to the patch in bug 255196).
Status: UNCONFIRMED → NEW
Ever confirmed: true

*** This bug has been marked as a duplicate of 255196 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.