Missing entities in Calendar translation

RESOLVED INVALID

Status

Mozilla Localizations
de / German
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Johannes Rohr, Assigned: Robert Kaiser)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041029 Firefox/1.0RC1 (Debian package 0.99+1.0RC1-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041029 Firefox/1.0RC1 (Debian package 0.99+1.0RC1-1)

In German mozilla 1.7, clicking a webcal link produces an XML error:

XML-Verarbeitungsfehler: Unbekannte Entity
Adresse: chrome://calendar/content/serverDialog.xul
Zeile Nr. 147, Spalte 42:

-----------------------<description>&calendar.server.dialog.username.label;</description>

The culprit is de-AT.jar/locale/de-AT/calendar/calendar.dtd:

You have to add 

<!ENTITY calendar.server.dialog.username.label "Benutzername">
<!ENTITY calendar.server.dialog.password.label "Passwort">

Thanks,

Johannes

Reproducible: Always
Steps to Reproduce:
1. Install German langpack
2.Visit icalshare.com
3. Click any webcal link
Actual Results:  
as described above

Expected Results:  
do I have to elaborate?
(Reporter)

Updated

13 years ago
Summary: XML error on clicking webcal link → Missing entities in Calendar translation
No, that is wrong. There are no username/password fields anymore in the server
dialog. Looks like you somehow have a old calendar + new translation.
(Reporter)

Comment 2

13 years ago
Well, Debian's Mozilla 1.7.3 ships with version 2004040813-cal of Calendar. This
looks pretty old, indeed. 

However, the Debian package header says "Source: mozilla", meaning it has been
build from the same source package as mozilla-*-1.7.3. Therefore I assumed that
this version was included with the official source for Mozilla 1.7.3.

If I'm wrong, please let me know. I will probably file a bug against
mozilla-calendar in Debian then.

Thanks,

Johannes
(Assignee)

Comment 3

13 years ago
Well, my XPI packages always contain the most recent translation, and in this
this case that means you have the trunk calendar localization with a branch
calendar which gives you the problems, but it's suitable for most other people
though.

This is an INVALID bug here, but you should file it with Debian, as you said.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

13 years ago
Well, this IS a problem for me, as I've mostly taken over maintenance of
mozilla-locale-de-at from Florian Weps.

In Debian, mozilla-{browser,mailnews,calendar} are built from a single source
package. I.e. the mozilla-calendar package in debian will always be the one with
has been current at the time of the latest mozilla release. 

You say that your langpack versioned 1.7.3 does _not_ match mozilla-calendar
included in the mozilla 1.7.3 sources but contains the translations for a newer
release/snapshot instead? Did I get it right? 

If so, where can I turn to retrieve the matching translation for the older
version/the diffs?

Thanks,

Johannes
(Reporter)

Comment 5

13 years ago
I forgot to say: I'm not going to file a bug against mozilla-calendar in Debian.
The only solution Debian could offer would be to build mozilla without calendar
and build calendar snapshots separately. I don't think I this proposal would
gain any support. 
You need to log in before you can comment on or make changes to this bug.