Status

P2
normal
VERIFIED DUPLICATE of bug 1729
20 years ago
14 years ago

People

(Reporter: dp, Assigned: morse)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
Suresh Duddi wrote:
>
> Username was NULL. This was the first time I used singlesignon with
> the current code base.
>
> went to netcenter and webmail. On initial login, it asked me if I
> wanted to save my username and password in the shell window (really
> cool). I said yes. It created signons.txt and then I quit.
>
> next time I started the viewer, I went to the same place but saw my
> username not filled in while my password was. I typed in my username
> and clicked on submit. It crashed.
>
> dp
>
> si_CheckForUser(char * 0x01306120, char * 0x00000000) line 519 + 9
> bytes
> si_OkToSave(MWContext_ * 0x011bf7e0, char * 0x01306120, char *
> 0x00000000) line 903 + 13 bytes
> SI_RememberSignonData(char * 0x01306120, LO_FormSubmitData_struct *
> 0x0012f988) line 1954 + 26 bytes
> nsNetlibService::SI_RememberSignonData(nsNetlibService * const
> 0x011debb0, char * 0x01306120, LO_FormSubmitData_struct * 0x0012f988)
> line 694 + 13 bytes
> nsFormFrame::ProcessAsURLEncoded(int 1, nsString & {...},
> nsIFormControlFrame * 0x012dc6cc) line 682 + 23 bytes
> nsFormFrame::OnSubmit(nsFormFrame * const 0x012d4944, nsIPresContext *
> 0x012bfd20, nsIFrame * 0x012dc670) line 497
> nsImageControlFrame::MouseClicked(nsIPresContext * 0x012bfd20) line
> 362
> nsImageControlFrame::HandleEvent(nsImageControlFrame * const
> 0x012dc670, nsIPresContext & {...}, nsGUIEvent * 0x0012fdb4,
> nsEventStatus & nsEventStatus_eIgnore) line 237
> PresShell::HandleEvent(PresShell * const 0x012537a4, nsIView *
> 0x012dc980, nsGUIEvent * 0x0012fdb4, nsEventStatus &
> nsEventStatus_eIgnore) line 1431 + 33 bytes
> nsView::HandleEvent(nsView * const 0x012dc980, nsGUIEvent *
> 0x0012fdb4, unsigned int 8, nsEventStatus & nsEventStatus_eIgnore)
> line 789
> nsView::HandleEvent(nsView * const 0x0127b7e0, nsGUIEvent *
> 0x0012fdb4, unsigned int 8, nsEventStatus & nsEventStatus_eIgnore)
> line 772
> nsView::HandleEvent(nsView * const 0x0127ba70, nsGUIEvent *
> 0x0012fdb4, unsigned int 28, nsEventStatus & nsEventStatus_eIgnore)
> line 772
> nsViewManager::DispatchEvent(nsViewManager * const 0x01253f40,
> nsGUIEvent * 0x0012fdb4, nsEventStatus & nsEventStatus_eIgnore) line
> 823
> HandleEvent(nsGUIEvent * 0x0012fdb4) line 64
> nsWindow::DispatchEvent(nsWindow * const 0x0127b130, nsGUIEvent *
> 0x0012fdb4, nsEventStatus & nsEventStatus_eIgnore) line 355 + 10 bytes
>
> nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012fdb4) line 371
> nsWindow::DispatchMouseEvent(unsigned int 301, nsPoint * 0x00000000)
> line 1849 + 15 bytes
> ChildWindow::DispatchMouseEvent(unsigned int 301, nsPoint *
> 0x00000000) line 1998
> nsWindow::ProcessMessage(unsigned int 514, unsigned int 0, long
> 16384282, long * 0x0012fef4) line 1388 + 24 bytes
> nsWindow::WindowProc(void * 0x001d05d8, unsigned int 514, unsigned int
> 0, long 16384282) line 414 + 27 bytes
> USER32! 77e71250()
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 1

20 years ago
Setting all current Open/Normal to M4.

Updated

20 years ago
Component: NetLib → Single Signon
Product: MozillaClassic → Browser
Version: 1998-03-31 → other

Updated

20 years ago
QA Contact: 3819

Comment 2

20 years ago
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 3

20 years ago
Part of this report (the crash part) is a duplicate of bug report 1729.  The
remaining part (about only the password being filled) in is not a bug but rather
a quirk of the netcenter login form.  Rather than being a single form, it
consists of one form for the username and a second form for the password.  When
a username is entered, it is reflected into a hidden field in the password form.
And it is the password form that is submitted to netcenter.  So the password is
what gets saved and restored.  The user name is not on the submitted form and so
cannot be saved.

It was apparent when single signon was designed that certain sites that used
unorthodox forms would not be save-able.  But it was clear that such sites would
be in the minority and so if the heuristic worked most of the time it would be
good enough.  It's unfortunate to discover that netcenter is one of those
unorthodox sites.  In any case, this part of the bug report is being considered
as INVALID.

Since the bug report has two parts, I have a choice now as to whether to close
it out as being a DUPLICATE or as being INVALID.  I'll choose the former.

*** This bug has been marked as a duplicate of 1729 ***

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 4

20 years ago
verified
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.