Access denied to XPConnect service

VERIFIED FIXED

Status

()

P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: rzach, Assigned: jband_mozilla)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

19 years ago
On Linux build 2000.02.05.08 I get this at startup:

JS Component Loader: ERROR (null):0
                     uncaught exception: Access denied to XPConnect service.
(Assignee)

Comment 1

19 years ago
reassigning to shaver. I hear he has a patch. I have not seen it.
Assignee: jband → shaver
Component: XPConnect → XPCOM
(Reporter)

Comment 2

19 years ago
I noticed that I don't get this message when I run as root.  Maybe you're trying
to write in the mozilla binary directory, which is read-only?

Updated

19 years ago
Blocks: 20721

Comment 3

19 years ago
marking beta1 because it blocks 20721
Keywords: beta1

Updated

19 years ago
Whiteboard: [PDT+]

Comment 4

19 years ago
No response form Mike, assigning to Norris per our discussion.
Assignee: shaver → norris
(Assignee)

Comment 5

19 years ago
I have a patch (which I attached to bug 20721) that worksforme on NT. rginda 
says that it does not solve the problem on his Linux box. This is a curiousity!
Assignee: norris → jband

Comment 6

19 years ago
It didn't work on Linux because jband's tree had changes not checked in.  All is
better now.
Checked in jband's patch.
(Assignee)

Comment 7

19 years ago
Marking fixed.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 8

19 years ago
Marking verified

























Status: RESOLVED → VERIFIED

Comment 9

19 years ago
*** Bug 39975 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.