Closed Bug 267396 Opened 16 years ago Closed 14 years ago

{inc} Content shifts upwards when focusing link inside table which has an image with white space

Categories

(Core :: Layout, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: martijn.martijn, Unassigned)

References

()

Details

(Keywords: testcase)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041030 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041030 Firefox/0.9.1+

This only happens in trunk (1.8a) builds.
See upcoming testcase.

When focusing the link (black image with green color above and below the image),
the green border disappears and the content below shifts upwards. 
This should not happen, everything should stay the way it was.

In the url testcase, you can see the bug by focusing the top image at the right
column.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Attached file Testcase
Blocks: 261196
Keywords: testcase
Same problem (using the testcase) under Linux/PPC, using Mozilla (CVS checkout
and compiled a few hours ago). Hardware/OS should be set to All/All.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050428
Firefox/1.0+

I cannot reproduce this with a focus, but I can reproduce it if I actually click
on that link.

When clicking on it, the green border disappears and the text shifts upwards.
Depends on: 263141
For the testcase: Shift-Reload then Reload then click the link.
Bug occurs in SeaMonkey 2006120701 (pre reflow branch) on Linux.
Bug does not occur in SeaMonkey 2006120801 (post reflow branch) on Linux.
Fixed by bug 300030, at least on Linux.
OS: Windows XP → All
Summary: Content shifts upwards when focusing link inside table which has an image with white space → {inc} Content shifts upwards when focusing link inside table which has an image with white space
Weirdness observed with:
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120606 Minefield/3.0a (pre-reflow branch)
(Load testcase, Ctrl-refresh, refresh, click, results in area resizing and then going back to original size)

No weirdness observed with:
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006120804 Minefield/3.0a1 (post-reflow branch)
(Load testcase, Ctrl-refresh, refresh, click, results in area size's staying constant)

Concur with comment 4

-->RESOLVED FIXED 

300030
Status: NEW → RESOLVED
Closed: 14 years ago
Depends on: reflow-refactor
Resolution: --- → FIXED
Flags: in-testsuite?
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.