Closed Bug 267919 Opened 18 years ago Closed 18 years ago

Firefox crashs if Adobe SVG plugin is not installed

Categories

(Toolkit Graveyard :: Plugin Finder Service, defect)

x86
Windows 2000
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kiouk, Assigned: doronr)

References

()

Details

(Keywords: crash, fixed-aviary1.0, fixed1.7.5)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2

I tryed show the
http://services.eoportal.org/portal/order/PrepareOperation.do?serviceId=CatalogueServiceId&serviceName=Products&operation=Search
page whith firefox with Adobe SVG plugin installed and it works perfecly.

But if plugin is not installed, firefox crashes.

Same result with windows XP and 2000

Reproducible: Always
Steps to Reproduce:
1.Go to URL page with no Adobe SVG
2.it crashes
3.Install Adobe SVG
4.Go to URL page
5.It works perfecly

Actual Results:  
Firefox crashes.

Expected Results:  
Firefox will ask if we want install adobe plugin
Did you get a talkback report?  I can't reproduce it, but others on irc said it
hanged for them. Doesn't happen on 1.7.3, so aviary only.
This site gets mozilla stuck in PresShell::ProcessReflowCommands() with a reflow
command that apparently doesn't want to be processed. The number of pending
reflow commands appears to remain at 2...
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is what dbaron and I came up with to fix this bug, the problem is that
SizeDiv() in nsObjectFrame ends up setting attributes from within reflow code,
which is a no-no. This fix makes the nsObjectFrame code pull the reflow command
caused by the attribute changes out of the queue, and this prevents this
infinite reflow loop.
Attachment #164799 - Attachment description: Evil fix that pull out style reflow commands for object child frames... → Evil fix that pulls style reflow commands for object child frames out of the reflow queue...
Attachment #164799 - Flags: superreview?(bzbarsky)
Attachment #164799 - Flags: review?(dbaron)
Flags: blocking-aviary1.0?
Attachment #164799 - Flags: review?(dbaron) → review+
Attachment #164799 - Flags: superreview?(bzbarsky) → superreview+
Fixed, a=asa from earlier today.
Status: NEW → RESOLVED
Closed: 18 years ago
Flags: blocking-aviary1.0? → blocking-aviary1.0+
Keywords: fixed-aviary1.0
Resolution: --- → FIXED
Keywords: crash
Are we tracking fixes like this that need to land on trunk as followups to the
plugin landing in some way?

I'd mark this as blocking the original bug that landed this stuff, but I can't
find that one...
Depends on: 244125
Should this be on 1.7 to keep sync with Gecko?
Michael, none of the dependencies of bug 244125 are on 1.7 yet.  In fact,
they're not even on trunk yet....
Keywords: fixed1.7.5
Product: Firefox → Toolkit
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.