Closed Bug 268151 Opened 18 years ago Closed 18 years ago

.mht "MHTML" files won't open + can't be viewed when click from a link

Categories

(Firefox :: File Handling, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 18764

People

(Reporter: dieyouyuppiescum, Assigned: bugs)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2

MHTML files will not open from links, and can't be opened from a file on a hard
drive. Basically, there appears to be no MHTML file support.

Reproducible: Always
Steps to Reproduce:
1. go to <a
href="http://staffweb.peoriaud.k12.az.us/Judy_Schwiebert/Science%20Sites/Science%20Resources.htm">http://staffweb.peoriaud.k12.az.us/Judy_Schwiebert/Science%20Sites/Science%20Resources.htm</a>
2. click on AP Biology
3. use any of the mentioned circumstances below to reproduce a result

Actual Results:  
-When clicking the link to the .mht file Firefox will treat the file as if it
needs to be downloaded.
-If you choose to open it with the default application M$ IE will open it (even
though M$ IE has been disabled and Mozilla 1.7 is installed and set as default
browser.)
-If you choose to have Firefox open it, an infinite loop of tabs will start to
open. If you close the page with the infinite loops and another page is open,
that page will start to have infinite loops of tabs occure. The same is true if
the download box is open when closing a page with infinite loops.
-If Firefox is set to always open .mht files and a link to an .mht file is
clicked an infite loop of tabs opening will also occure.

*Please note that I have all page set in open up in new tabs.


Expected Results:  
When clicking a link to an .mht file from a webpage, the page should load + be
viewed just like any standard .html page.  Also, Firefox should be able to open
the MHTML file (when using File > open file...)

Both Mozilla 1.7 and M$ IE 6(SP2) will dispaly the MHTML file just like a HTML
file when clicked from a link.
Both Mozilla 1.7 and M$ IE 6(SP2) will open and .mht file.

I have Mozilla 1.7 installed also.
I have Windows XP SP2 installed.
This bug was also present in Firefox RC1.

*** This bug has been marked as a duplicate of 18764 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.